Bug 487986 - autofs should always read file maps
autofs should always read file maps
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Ian Kent
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-01 21:06 EST by Ian Kent
Modified: 2009-09-03 10:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, autofs would not always read file maps. If a map had been loaded into cache, autofs would rely on checks to determine whether the map was up to date before reading the map. Because file maps require a linear search through the file, large maps consume significant resources to process. Now, autofs automatically loads file-based maps when it starts, and uses the map file mtime parameter to detemine whether the cache needs to be refresed. This avoids the processing overhead of checking a map before deciding whether to load it.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:59:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Kent 2009-03-01 21:06:03 EST
Description of problem:

At start autofs tries not to load an entire map into the internal
cache unless it has to. For maps that do get loaded into the
cache it relies on checks to work out if a map is up to date
in order to trigger a map read. This is fine for maps that can
do direct key lookups but file maps need to do a linear search
through the file when locating an entry for a key. For large maps
this can be a huge overhead.

autofs should always load file based maps at start and make use
of the map file mtime to discover if the cache needs to be
refreshed.
Comment 2 Ian Kent 2009-05-20 23:49:01 EDT
This issue has been fixed in the latest autofs package
autofs-5.0.1-0.rc2.125.

I've been unable to devise a way to test this within RHTS.
However, when running the tests in our of battery of regression
tests I found (and fixed) several regressions that had been
introduced by the change.

So verifying this change amounts to autofs passing those existing
regression tests is is supposed to, which is pretty much all of
them now.
Comment 5 Ruediger Landmann 2009-08-31 01:19:10 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Previously, autofs would not always read file maps. If a map had been loaded into cache, autofs would rely on checks to determine whether the map was up to date before reading the map. Because file maps require a linear search through the file, large maps consume significant resources to process. Now, autofs automatically loads file-based maps when it starts, and uses the map file mtime parameter to detemine whether the cache needs to be refresed. This avoids the processing overhead of checking a map before deciding whether to load it.
Comment 6 errata-xmlrpc 2009-09-02 07:59:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1397.html

Note You need to log in before you can comment on or make changes to this bug.