Bug 488039 - End key and Home key can't make effect to the firefox
End key and Home key can't make effect to the firefox
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firefox (Show other bugs)
4.9
s390x Linux
low Severity low
: rc
: ---
Assigned To: Gecko Maintainer
desktop-bugs@redhat.com
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-02 05:22 EST by Huangzizhe
Modified: 2009-03-11 02:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 02:36:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of xev (25.87 KB, text/plain)
2009-03-10 04:20 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Huangzizhe 2009-03-02 05:22:12 EST
Description of problem:
End key and Home key can't make effect to the firefox

Version-Release number of selected component (if applicable):
firefox-3.0.7-1

How reproducible:
Always

Steps to Reproduce:
1.Open a web page such as http://news.google.com/.
2.In the page,Press End key.
3.In the page,Press Home key.
  
Actual results:
End key and Home key don't work

Expected results:
it will go to bottom of the page.
it will go to top of the page.

Additional info:
Comment 1 Matěj Cepl 2009-03-04 04:37:55 EST
a) Cannot reproduce here with firefox-3.0.6-1.el4.s390x. Hone/End keys just work. Most likely there is soemthing wrong in the setting of your cnv client or something of that sort.
b) Even if there was a bug, this bug is filed against release of RHEL, which is in maintenance phase. During the maintenance phase, only security errata and select mission critical bug fixes will be released for enterprise products. Since this bug does not meet that criteria, it is now being closed.

For more information of the RHEL errata support policy, please visit:

http://www.redhat.com/security/updates/errata/
Comment 2 Matěj Cepl 2009-03-09 10:49:45 EDT
OK, after long discussion on IRC, I am reopening this bug. Let's try to find out what's the problem.

a) are you able to reproduce this bug?
b) could you please tell me which machine (hostname) you use and how do you get there (vnc or ssh -Y)?
c) any other interesting condition of your configuration, infrastructure, whatever, which could help me to reproduce it here?

Thanks a lot.
Comment 3 Radek Bíba 2009-03-09 11:45:13 EDT
d) please make sure the browser window is focused; this isn't as straightforward as it would seem if you're working with TWM in VNC (what did you actually use, BTW?)
e) is really only firefox affected or do the keys not work in any other GUI applications? What about other Gecko-based stuff, like seamonkey and thunderbird?
f) you mean normal Home and End keys, not the ones on numeric keypad with Num Lock on, right?

(sorry if these questions sound lame, I'm just trying to gather as much information as possible)
Comment 4 Huangzizhe 2009-03-09 22:04:07 EDT
a) I can reproduce this bug
b) s390x-4as-v1.z900.redhat.com.I use vnc to get there
c) I use the stable system.so I don't know the infrastructure.and I don't change the configuration
d) I make sure the browser window is focused.I use vnc
e) it only firefox affected,it works in seamonkey
f) I mean normal Home and End keys
Comment 5 Matěj Cepl 2009-03-10 04:20:05 EDT
Created attachment 334601 [details]
output of xev

Curiouser and Curiouser! I have actually tried to reproduce your bug, and even when I did:

1) vncviewer -via matej@s390x-4as-v1.z900.redhat.com localhost:3
2) firefox
3) Ctrl-L -- Home/End works as expected
4) news.google.com
5) click to the page, so that it has focus
6) End jumps to the end of the page

You obviously have some problem with vnc. Could you please run

xev 2>&1 |tee xev-log.txt

and then press Home/End (you need to kill xev with mouse), and then attach xev-log.txt to this bug, please?
Comment 6 Huangzizhe 2009-03-11 02:36:12 EDT
I can't reproduce this bug now. but it indeed reproduce last time. maybe there are some problem with vnc.

Note You need to log in before you can comment on or make changes to this bug.