Bug 488061 - -fno-tree-sra -> internal compiler error: SSA corruption
-fno-tree-sra -> internal compiler error: SSA corruption
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-02 07:54 EST by Yanko Kaneti
Modified: 2009-03-04 14:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 14:00:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed source (1.96 MB, application/octet-stream)
2009-03-02 07:54 EST, Yanko Kaneti
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 39362 None None None Never

  None (edit)
Description Yanko Kaneti 2009-03-02 07:54:22 EST
Created attachment 333730 [details]
preprocessed source

gcc-4.4.0-0.21.1.i586

WebKit-gtk also seems to be affected by the rawhide upgrade to gcc-4.4. Following the advice of bug 487795 I tried to recompile it with -fno-tree-sra but got the following ICE.

Unable to coalesce ssa_names 534 and 155 which are marked as MUST COALESCE.
D.219586_534(ab) and  D.219586_155(ab)
WebCore/page/AccessibilityRenderObject.cpp: In member function 'virtual void WebCore::AccessibilityRenderObject::addChildren()':
WebCore/page/AccessibilityRenderObject.cpp:2303: internal compiler error: SSA corruption

Attaching the preprocessed source.
Comment 1 Jakub Jelinek 2009-03-02 12:11:06 EST
I'll look at it.  That said, the advice in #487795 was for that bug, isn't something that should be blindly used for other packages.  Instead you should first look at possible aliasing warnings, fix them, try building with -O0 to see if it helps, if yes, try also -O2 -fno-strict-aliasing, do a binary search between flags that work and flags that don't to find problematic compilation unit, etc.
Comment 2 Yanko Kaneti 2009-03-03 06:04:07 EST
I would have, but I am quite ignorant on the whole aliasing issue. And there are many aliasing warnings building WebKit/JavaScriptCore. Sorry.
Comment 3 Jakub Jelinek 2009-03-04 14:00:35 EST
Tracking this upstream.

Note You need to log in before you can comment on or make changes to this bug.