Bug 488069 - Fedora 11 / rawhide trees have broken .treeinfo files
Fedora 11 / rawhide trees have broken .treeinfo files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-02 08:57 EST by Daniel Berrange
Modified: 2013-01-10 00:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 13:45:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2009-03-02 08:57:18 EST
Description of problem:
Todays Fedora 11 rawhide compose has a .treeinfo file containing


[images-i386]
initrd = images/pxeboot/initrd.img
boot.iso = images/boot.iso
kernel = images/pxeboot/vmlinuz

[stage2]
mainimage = images/install.img

[images-xen]
initrd = images/pxeboot/initrd-PAE.img
kernel = images/pxeboot/vmlinuz-PAE

[general]
family = Fedora
timestamp = 1235897570.93
variant = 
totaldiscs = 1
version = development
discnum = 1
packagedir = 
arch = i586



Note, that 'arch' field in the [general] section is 'i586', but the images section is [images-i386].  This breaks installation of guest virtual machines, because virt-install sees an arch of 'i586' and tries to find [images-i586] which does not exist.


Either the 'arch' field needs to be put back to i386, or the 'images-$ARCH' section needs to be images-i586 and not images-i386.


Version-Release number of selected component (if applicable):
Rawhide as of 2009-03-02 compose

How reproducible:
Always

Steps to Reproduce:
1.virt-install --file /dev/HostVG/f11i386 --ram 800 --location http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/ --hvm --vnc --noautoconsole --name f11i386 --accelerate --os-type linux --os-variant fedora11

2.
3.
  
Actual results:
ERROR    No section: 'images-i586'


Expected results:
Guest install starts.

Additional info:
Comment 1 Daniel Berrange 2009-03-02 09:06:31 EST
Also appears that the 'images-i386' section refers to 'images/pxeboot/vmlinuz' which does not exist - only 'images/pxeboot/vmlinuz-PAE'. Unclear whether this is another bug and it should point to vmlinuz-PAE too, or whether 'vmlinuz' is intended, and it just failed to build in today's rawhide compose
Comment 2 Daniel Berrange 2009-03-02 13:30:44 EST
Pointer to upstream bugreport against anaconda

https://www.redhat.com/archives/anaconda-devel-list/2009-February/thread.html
Comment 3 Chris Lumens 2009-03-17 11:08:21 EDT
Looking at today's .treeinfo file, I see an [images-i386] section, arch = i386 in [general], a reference to images/pxeboot/vmlinuz, and that file in the tree as expected.  This is in addition to references to vmlinuz-PAE.

Can you please try another install and verify that it's working for you now?  Thanks.
Comment 4 Daniel Berrange 2009-03-17 13:45:03 EDT
Yes, today's rawhide is working correctly

Note You need to log in before you can comment on or make changes to this bug.