Bug 488093 - doc build failure with xmlto-0.0.21-3.fc10 and later
doc build failure with xmlto-0.0.21-3.fc10 and later
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xmlto (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-02 11:25 EST by Nicolas Chauvet (kwizart)
Modified: 2009-03-09 11:09 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.0.21-4.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-03 10:26:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2009-03-02 11:25:46 EST
Description of problem:


Version-Release number of selected component (if applicable):
xmlto-0.0.21-3.fc10 and later

How reproducible: always


Steps to Reproduce:
1. build lcdproc in F-10 with current updates (including xmlto-0.0.21-3.fc10)
The build will fails
2. rpm -e xmlto ; yum install xmlto --disable repo=updates
3. build lcdproc with the GA xmlto version:
The build will succeed
  
Actual results:


Expected results:


Additional info: There is a need to check if the patches haven't introduced regression. If not, please provide advices about how to fix the doc compilation.
Comment 1 Nicolas Chauvet (kwizart) 2009-03-02 11:26:50 EST
here is a buildfailure for a sample:
http://koji.fedoraproject.org/koji/getfile?taskID=1170430&name=build.log
Comment 2 Ondrej Vasik 2009-03-02 12:08:42 EST
Thanks for report, it seems to be caused by addition of --noent option to xmllint validation (requested by Debian maintainer, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=483503 for details). Easiest fix is to disable --noent option at the moment ... but it may cause build failures to other docs builds. Will disable it in Rawhide and try to find something more suitable meanwhile.
Comment 3 Fedora Update System 2009-03-02 12:32:20 EST
xmlto-0.0.20-5.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xmlto-0.0.20-5.fc9
Comment 4 Fedora Update System 2009-03-02 12:32:20 EST
xmlto-0.0.21-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xmlto-0.0.21-4.fc10
Comment 5 Fedora Update System 2009-03-03 10:26:05 EST
xmlto-0.0.20-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-03-03 10:27:39 EST
xmlto-0.0.21-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Ondrej Vasik 2009-03-09 11:00:28 EDT
Just FYI - will revert noent option soon in RAWHIDE - so if you want to keep your docs (almost) untouched, just add --skip-validation option to after xmlto commands. As xmllint fails with "/koji/lcdproc/devel/lcdproc-0.5.2/docs/lcdproc-dev/lcdproc-dev.docbook:1306: element term: validity error : Element arg is not declared in term list of possible children" and similar errors, I guess lcdproc doc sources should be improved - but as the documentation looks ok with --skip-validation option passed to xmlto, it is the easiest solution.
Comment 8 Nicolas Chauvet (kwizart) 2009-03-09 11:09:25 EDT
okay, thx for the advices.

Note You need to log in before you can comment on or make changes to this bug.