Bug 488127 - [RHEL5] ghostscript /rangecheck in --cvrs--
Summary: [RHEL5] ghostscript /rangecheck in --cvrs--
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ghostscript   
(Show other bugs)
Version: 5.3
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: 5.4
Assignee: Tim Waugh
QA Contact: QE Internationalization Bugs
URL:
Whiteboard:
Keywords:
: 494792 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-03-02 20:04 UTC by Robin R. Price II
Modified: 2018-10-20 02:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 09:12:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ghostscript-cvrs-overflow.patch (894 bytes, patch)
2009-03-12 13:44 UTC, Tim Waugh
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1257 normal SHIPPED_LIVE ghostscript bug fix update 2009-09-01 09:09:13 UTC

Description Robin R. Price II 2009-03-02 20:04:43 UTC
Description of problem:

ghostscript package fails to use gs and pdf2ps correctly.  PDF files that have boxes and formatting in them are failing.

Version-Release number of selected component (if applicable):

# rpm -q ghostscript
ghostscript-8.15.2-9.4.el5.x86_64
ghostscript-8.15.2-9.4.el5.i386


How reproducible:

ALWAYS

Steps to Reproduce:
1. Generate a PDF 
2. Run gs -dNODISPLAY foo.pdf
or
3. pdf2ps foo.pdf foo.ps 
  
Actual results:

 gs -dNODISPLAY foo.pdf 
ESP Ghostscript 815.02 (2006-04-19)
Copyright (C) 2004 artofcode LLC, Benicia, CA.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Processing pages 1 through 1.
Page 1
Loading NimbusSanL-Bold font from /usr/share/fonts/default/Type1/n019004l.pfb... 3114160 1791270 2103592 490421 3 done.
Using NimbusSansL-Bold font for NimbusSanL-Bold.
Loading NimbusSanL-Regu font from /usr/share/fonts/default/Type1/n019003l.pfb... 3268544 1947977 2123776 505056 3 done.
Using NimbusSansL-Regu font for NimbusSanL-Regu.
Loading NimbusRomNo9L-Regu font from /usr/share/fonts/default/Type1/n021003l.pfb... 3472816 2156433 2123776 513195 3 done.
Using NimbusRomanNo9L-Regu font for NimbusRomNo9L-Regu.
Loading NimbusRomNo9L-Medi font from /usr/share/fonts/default/Type1/n021004l.pfb... 3677296 2362295 2143960 522800 3 done.
ERROR: /rangecheck in --cvrs--
Operand stack:
   --dict:7/7(L)--   F4   22.0   --dict:6/6(L)--   --dict:6/6(L)--   WCSUDE+SecureNumber_X9602   --dict:10/12(ro)(G)--   --nostringval--   --dict:7/7(L)--   --dict:7/7(L)--   105353   --dict:7/7(L)--   --nostringval--   FontMatrix   --nostringval--   FontBBox   --nostringval--   FontName   -2147483647   16   (\000\000\000\000\000\000\000\000)
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   --nostringval--   --nostringval--   2   1   1   --nostringval--   %for_pos_int_continue   --nostringval--   --nostringval--   --nostringval--   --nostringval--   %array_continue   --nostringval--   false   1   %stopped_push   --nostringval--   %loop_continue   --nostringval--   --nostringval--   --nostringval--   --nostringval--   --nostringval--   %array_continue   --nostringval--   --nostringval--   --nostringval--   --nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1118/1686(ro)(G)--   --dict:0/20(G)--   --dict:107/200(L)--   --dict:107/200(L)--   --dict:104/127(ro)(G)--   --dict:241/347(ro)(G)--   --dict:20/24(L)--   --dict:4/6(L)--   --dict:25/32(L)--   --dict:33/50(ro)(G)--   --dict:24/40(L)--
Current allocation mode is local
ESP Ghostscript 815.02: Unrecoverable error, exit code 1


----

$ pdf2ps foo.pdf foo.ps
ERROR: /rangecheck in --cvrs--
Operand stack:
   --dict:7/7(L)--   F4   22.0   --dict:6/6(L)--   --dict:6/6(L)--   WCSUDE+SecureNumber_X9602   --dict:10/12(ro)(G)--   --nostringval--   --dict:7/7(L)--   --dict:7/7(L)--   105353   --dict:7/7(L)--   --nostringval--   FontMatrix   --nostringval--   FontBBox   --nostringval--   FontName   -2147483647   16   (\000\000\000\000\000\000\000\000)
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   --nostringval--   --nostringval--   2   1   1   --nostringval--   %for_pos_int_continue   --nostringval--   --nostringval--   --nostringval--   --nostringval--   %array_continue   --nostringval--   false   1   %stopped_push   --nostringval--   %loop_continue   --nostringval--   --nostringval--   --nostringval--   --nostringval--   --nostringval--   %array_continue   --nostringval--   --nostringval--   --nostringval--   --nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1119/1686(ro)(G)--   --dict:0/20(G)--   --dict:107/200(L)--   --dict:107/200(L)--   --dict:104/127(ro)(G)--   --dict:241/347(ro)(G)--   --dict:20/24(L)--   --dict:4/6(L)--   --dict:25/32(L)--   --dict:33/50(ro)(G)--   --dict:24/40(L)--
Current allocation mode is local
ESP Ghostscript 815.02: Unrecoverable error, exit code 1



Expected results:

Conversion should work correctly.


Additional info:

foo.pdf in the example is a CheckSample.pdf from an application.  It is setup with a check template and invoice template.

This works correctly in RHEL4.
This also works with the latest upstream ghostscript version.

Comment 1 Tim Waugh 2009-03-11 17:06:58 UTC
Please supply a test case.  Thanks.

Comment 2 Tim Waugh 2009-03-11 17:13:35 UTC
Oh, never mind, it was sent in private mail.

Comment 4 Tim Waugh 2009-03-12 13:44:53 UTC
Created attachment 334926 [details]
ghostscript-cvrs-overflow.patch

This is the fix, backported from 8.64.

Comment 5 Robin R. Price II 2009-03-12 14:19:07 UTC
Thanks Tim,  I will spin a test package from this.

-- Robin

Comment 6 Robin R. Price II 2009-03-12 20:53:57 UTC
Spun a quick set of packages.  So far they work on my end.

http://people.redhat.com/rprice/BZ488127/

-- Robin

Comment 10 Robin R. Price II 2009-03-23 16:08:46 UTC
Moved the bzlink to my cups directory and added the src rpm for users.

http://people.redhat.com/rprice/cups/bz488127/

-- Robin

Comment 12 Tim Waugh 2009-04-08 08:34:57 UTC
*** Bug 494792 has been marked as a duplicate of this bug. ***

Comment 15 errata-xmlrpc 2009-09-02 09:12:10 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1257.html


Note You need to log in before you can comment on or make changes to this bug.