Bug 488143 - Assertion 'pa_object_refcnt(pa_object_cast(o)) > 0' failed
Assertion 'pa_object_refcnt(pa_object_cast(o)) > 0' failed
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-02 16:03 EST by Bernie Innocenti
Modified: 2009-03-30 13:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-30 13:33:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernie Innocenti 2009-03-02 16:03:46 EST
This happens shortly after running the daemon on the command line,
and it makes the daemon die:

core.h: Assertion 'pa_object_refcnt(pa_object_cast(o)) > 0' failed at ./pulsecore/core.h:159, function pa_core_assert_ref(). Aborting.

The following modules are installed:

bernie@bender:~$ rpm -qa | grep ^pulseaudio | sort
pulseaudio-0.9.15-3.test3.fc11.x86_64
pulseaudio-libs-0.9.15-3.test3.fc11.x86_64
pulseaudio-libs-devel-0.9.15-3.test3.fc11.x86_64
pulseaudio-libs-glib2-0.9.15-3.test3.fc11.x86_64
pulseaudio-libs-zeroconf-0.9.15-3.test3.fc11.x86_64
pulseaudio-module-bluetooth-0.9.15-3.test3.fc11.x86_64
pulseaudio-module-gconf-0.9.15-3.test3.fc11.x86_64
pulseaudio-module-x11-0.9.15-3.test3.fc11.x86_64
pulseaudio-module-zeroconf-0.9.15-3.test3.fc11.x86_64
pulseaudio-utils-0.9.15-3.test3.fc11.x86_64

Contents of /var/log/messages:

Mar  2 21:37:19 bender pulseaudio[29681]: main.c: Called SUID root and real-time and/or high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
Mar  2 21:37:19 bender pulseaudio[29681]: main.c: We are not in group 'pulse-rt', PolicyKit refuse to grant us the requested privileges and we have no increase RLIMIT_NICE/RLIMIT_RTPRIO resource limits.
Mar  2 21:37:19 bender pulseaudio[29681]: main.c: For enabling real-time/high-priority scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user. 
Mar  2 21:37:19 bender pulseaudio[29684]: pid.c: Stale PID file, overwriting.
Mar  2 21:37:19 bender pulseaudio[29684]: alsa-util.c: Cannot find fallback mixer control "Mic" or mixer control is no combination of switch/volume.
Mar  2 21:37:22 bender pulseaudio[29684]: alsa-source.c: Increasing minimal latency to 8.00 ms
Mar  2 21:37:22 bender pulseaudio[29684]: alsa-source.c: Increasing minimal latency to 8.00 ms
Mar  2 21:37:22 bender pulseaudio[29684]: alsa-source.c: Increasing minimal latency to 16.00 ms
Mar  2 21:37:22 bender pulseaudio[29684]: alsa-sink.c: Increasing minimal latency to 8.00 ms
Mar  2 21:37:22 bender pulseaudio[29684]: alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write!
Mar  2 21:37:22 bender pulseaudio[29684]: alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA developers.
Mar  2 21:37:22 bender pulseaudio[29684]: alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
Mar  2 21:37:22 bender pulseaudio[29684]: alsa-source.c: Increasing minimal latency to 26.00 ms
Mar  2 21:37:22 bender pulseaudio[29684]: alsa-source.c: Increasing wakeup watermark to 15.99 ms
Mar  2 21:37:22 bender pulseaudio[29684]: alsa-source.c: Increasing minimal latency to 36.00 ms
Mar  2 21:37:22 bender pulseaudio[29684]: alsa-source.c: Increasing wakeup watermark to 25.99 ms
Mar  2 21:37:22 bender pulseaudio[29684]: alsa-source.c: Increasing minimal latency to 16.00 ms
Mar  2 21:37:22 bender pulseaudio[29684]: alsa-sink.c: Increasing minimal latency to 16.00 ms
Mar  2 21:37:28 bender pulseaudio[29684]: ratelimit.c: 129 events suppressed
Mar  2 21:37:28 bender pulseaudio[29684]: alsa-source.c: Increasing minimal latency to 26.00 ms
Mar  2 21:37:43 bender pulseaudio[29684]: core.h: Assertion 'pa_object_refcnt(pa_object_cast(o)) > 0' failed at ./pulsecore/core.h:159, function pa_core_assert_ref(). Aborting.
Comment 1 Lennart Poettering 2009-03-30 10:43:06 EDT
Hmm, any chance you can get me a stack trace of this?
Comment 2 Bernie Innocenti 2009-03-30 13:33:19 EDT
It stopped happening a while ago.

Could be because I disabled the bluetooth module... or because of updates in rawhide.  I will reopen it if it ever happens again.

Note You need to log in before you can comment on or make changes to this bug.