Bug 488191 - When adding system into failover domain with system-config-cluster, it will remove "_" from node name if the name has "_".
When adding system into failover domain with system-config-cluster, it will ...
Status: CLOSED DUPLICATE of bug 352631
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-cluster (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-02 23:53 EST by Zhenyong(Jerry) Jiang
Modified: 2013-07-28 20:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-26 16:31:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhenyong(Jerry) Jiang 2009-03-02 23:53:49 EST
Description of problem:

When adding system into failover domain with system-config-cluster,  it will remove "_" from node name if the name has "_".

Version-Release number of selected component (if applicable):

system-config-cluster-1.0.55-1.0

How reproducible:

100%

Steps to Reproduce:
1. Run system-config-cluster, create nodes named node_1, node_2 ( make sure there is a "_" in node name )
2. Create a failover domain, and add the above nodes into this domain, you can find system-config-cluster removes the "_" from the node name.
3. Check the file /etc/cluster/cluster.conf, and find the node name in failover domain has no "_"

This can cause service fail to auto-start when system booting up if "stricted=1"  is enabled.
  
Actual results:

system-config-cluster remove the letter "_" from node name in failover domain.

Expected results:

system-config-cluster should keep the right host name in anywhere 

Additional info:

Manually edit /etc/cluster/cluster.conf can make cluster work well.
Comment 1 Ryan McCabe 2010-10-26 16:31:57 EDT

*** This bug has been marked as a duplicate of bug 352631 ***

Note You need to log in before you can comment on or make changes to this bug.