Bug 488245 - ISE if session expires and you attempt to reload on a pxt page
ISE if session expires and you attempt to reload on a pxt page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Shannon Hughes
John Matthews
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-03-03 08:55 EST by John Matthews
Modified: 2009-09-10 16:33 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:33:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2009-03-03 08:55:55 EST
Description of problem:

Go to a .pxt page in Satellite, keep this page open in a separate tab.  Open another page (new tab) to the same satellite, click signout, then reload prior .pxt page in other tab.  Observe ISE

Below are the 2 .pxts I've been seeing this on
/network/software/channels/manage/index.pxt
/network/systems/ssm/index.pxt

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090227.1-i386-embedded-oracle.iso

How reproducible:
Always.

I reproduced this on 2 Sats from ISO 20090227.1  


Steps to Reproduce:
1. Requires 2 tabs in a browser
2. In tab1: Login to Sat
3. In tab1 go to: /network/software/channels/manage/index.pxt
4. In tab2 go to Sat, any page
5. In tab2 "sign-out" 
6. In tab1 refresh page (should be refresh of /network/software/channels/manage/index.pxt)
7. Observe ISE
  
Actual results:
ISE:  ORA-22922: nonexistent LOB value

Expected results:
Redirect to login page

Additional info:


2009-03-02 21:36:56,155 [TP-Processor3] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 22922, SQLState: 99999
2009-03-02 21:36:56,156 [TP-Processor3] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-22922: nonexistent LOB value

2009-03-02 21:36:56,158 [TP-Processor3] ERROR org.hibernate.event.def.AbstractFlushingEventListener - Could not synchronize database state with session
org.hibernate.exception.GenericJDBCException: could not update: [com.redhat.rhn.domain.satellite.SatelliteCertificate#1]
        at org.hibernate.exception.SQLStateConverter.handledNonSpecificException(SQLStateConverter.java:103)
        at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.java:91)
        at org.hibernate.exception.JDBCExceptionHelper.convert(JDBCExceptionHelper.java:43)
        at org.hibernate.persister.entity.AbstractEntityPersister.update(AbstractEntityPersister.java:2425)
        at org.hibernate.persister.entity.AbstractEntityPersister.updateOrInsert(AbstractEntityPersister.java:2307)
        at org.hibernate.persister.entity.AbstractEntityPersister.update(AbstractEntityPersister.java:2607)
        at org.hibernate.action.EntityUpdateAction.execute(EntityUpdateAction.java:92)
        at org.hibernate.engine.ActionQueue.execute(ActionQueue.java:250)
        at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:234)
        at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:142)
        at org.hibernate.event.def.AbstractFlushingEventListener.performExecutions(AbstractFlushingEventListener.java:298)
        at org.hibernate.event.def.DefaultFlushEventListener.onFlush(DefaultFlushEventListener.java:27)
        at org.hibernate.impl.SessionImpl.flush(SessionImpl.java:1000)
        at org.hibernate.impl.SessionImpl.managedFlush(SessionImpl.java:338)
        at org.hibernate.transaction.JDBCTransaction.commit(JDBCTransaction.java:106)
        at com.redhat.rhn.common.hibernate.ConnectionManager.commitTransaction(ConnectionManager.java:201)
        at com.redhat.rhn.common.hibernate.HibernateFactory.commitTransaction(HibernateFactory.java:274)
        at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:56)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)
        at java.lang.Thread.run(Thread.java:735)
Caused by: 
java.sql.SQLException: ORA-22922: nonexistent LOB value
Comment 1 Jesus M. Rodriguez 2009-03-18 10:06:24 EDT
This is odd to see a Java stacktrace when browing a pxt page. This means that the pxt side of things did the right thing and redirected to the java login page. But during the loading of the login page we hit the above error.
Comment 2 Shannon Hughes 2009-04-13 16:40:25 EDT
i know this was a problem earlier. i was able to duplicate it with sats but not in my environment. jdobs was able to duplicate it in his environment so i am thinking it was/is a config issue. this is working though in the latest iso. can we have a retest of this bug?
Comment 3 John Matthews 2009-04-13 16:44:56 EDT
Checked it on latest ISO, don't see the problem.
 
ISO: Satellite-5.3.0-RHEL5-re20090409.1-i386-embedded-oracle.iso
Comment 4 Preethi Thomas 2009-08-26 09:10:50 EDT
Release Pending
no ise on the above scenario.
Comment 5 Brandon Perkins 2009-09-10 16:33:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.