This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 488378 - repodata xmlrpc call response is not parsable by rhnlib
repodata xmlrpc call response is not parsable by rhnlib
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
RHN Stable
All Linux
low Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Red Hat Network Quality Assurance
:
Depends On:
Blocks: 249376 489761
  Show dependency treegraph
 
Reported: 2009-03-03 18:06 EST by Pradeep Kilambi
Modified: 2013-01-10 04:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 16:47:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2009-03-03 18:06:26 EST
Description of problem:

calling "repodata" rpc call in sat handler sends down a response, but is not parsable by rhnlib.

<xmlrpclib.ResponseError instance at 0xa369e8c>

  File "/usr/share/rhn/satellite_tools/xmlWireSource.py", line 473, in getChannelCompsStream
    return self._rpc_call("repodata", (channel, file_name))
  File "/usr/share/rhn/satellite_tools/xmlWireSource.py", line 436, in _rpc_call
    ret = apply(getattr(get_server_obj, function_name), params)
  File "/usr/lib/python2.4/site-packages/rhn/rpclib.py", line 622, in __call__
    result = self._send(self._name, args)
  File "/usr/lib/python2.4/site-packages/rhn/rpclib.py", line 319, in _request
    request, verbose=self._verbose)
  File "/usr/lib/python2.4/site-packages/rhn/transports.py", line 187, in request
    return self._process_response(fd, connection)
  File "/usr/lib/python2.4/site-packages/rhn/transports.py", line 215, in _process_response
    return self.parse_response(fd)
  File "/usr/lib/python2.4/site-packages/rhn/transports.py", line 239, in parse_response
    return u.close()
  File "/usr/lib/python2.4/xmlrpclib.py", line 742, in close
    raise ResponseError()
ResponseError: <xmlrpclib.ResponseError instance at 0xa42d72c>


The problem I think is with the content type in the response header. It seems to be None and hence python xmlrpclib is raising the exception.

Note You need to log in before you can comment on or make changes to this bug.