Bug 488393 - One of these packages broke input in wine
One of these packages broke input in wine
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-03 21:41 EST by D Levin
Modified: 2014-01-21 18:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 10:14:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description D Levin 2009-03-03 21:41:23 EST
Description of problem:
Last night I updated my system (see list, below) and when I was done, wine apps could accept input from the keyboard.


Version-Release number of selected component (if applicable):
Mar 02 22:48:19 Updated: evolution-data-server-doc-2.24.5-1.fc10.i386
Mar 02 22:48:44 Updated: selinux-policy-3.5.13-46.fc10.noarch
Mar 02 22:48:45 Updated: kernel-firmware-2.6.27.19-170.2.35.fc10.noarch
Mar 02 22:49:22 Updated: selinux-policy-targeted-3.5.13-46.fc10.noarch
Mar 02 22:49:25 Updated: kernel-headers-2.6.27.19-170.2.35.fc10.i386
Mar 02 22:49:35 Installed: kernel-devel-2.6.27.19-170.2.35.fc10.i686
Mar 02 22:49:38 Updated: evolution-data-server-2.24.5-1.fc10.i386
Mar 02 22:49:40 Updated: gtkhtml3-3.24.5-1.fc10.i386
Mar 02 22:50:28 Updated: evolution-2.24.5-1.fc10.i386
Mar 02 22:50:29 Updated: SDL-1.2.13-7.fc10.i386
Mar 02 22:50:29 Updated: 1:cups-libs-1.3.9-8.fc10.i386
Mar 02 22:50:30 Updated: linuxwacom-0.8.0.3-8.fc10.i386
Mar 02 22:50:31 Updated: libgxim-0.3.2-3.fc10.i386
Mar 02 22:50:33 Updated: anthy-9100h-1.fc10.i386
Mar 02 22:50:36 Updated: 1:cups-1.3.9-8.fc10.i386
Mar 02 22:50:37 Updated: xorg-x11-drv-vmmouse-12.6.3-3.fc10.i386
Mar 02 22:50:40 Updated: evolution-help-2.24.5-1.fc10.i386
Mar 02 22:50:40 Updated: evolution-perl-2.24.5-1.fc10.i386
Mar 02 22:50:41 Updated: SDL-devel-1.2.13-7.fc10.i386
Mar 02 22:50:41 Updated: alsa-utils-1.0.19-2.fc10.i386
Mar 02 22:50:42 Updated: evolution-data-server-devel-2.24.5-1.fc10.i386
Mar 02 22:51:00 Installed: kernel-2.6.27.19-170.2.35.fc10.i686
Mar 02 22:51:09 Installed: kernel-2.6.27.19-170.2.35.fc10.i686



How reproducible:


Steps to Reproduce:
1. Install the above
2. reboot
3. run wine->notepad, will not accept input
  
Actual results:


Expected results:


Additional info:
Tonight I added, and after reboot, wine apps still broken.

Mar 03 20:44:33 Installed: system-config-date-1.9.36-1.fc10.noarch
Mar 03 20:44:35 Installed: system-config-date-docs-1.0.5-1.fc10.noarch
Mar 03 20:44:37 Updated: gvfs-1.0.3-6.fc10.i386
Mar 03 20:44:38 Updated: audit-libs-1.7.12-1.fc10.i386
Mar 03 20:44:38 Updated: gvfs-smb-1.0.3-6.fc10.i386
Mar 03 20:44:38 Updated: gvfs-fuse-1.0.3-6.fc10.i386
Mar 03 20:44:38 Updated: audit-libs-python-1.7.12-1.fc10.i386
Mar 03 20:44:39 Updated: gvfs-archive-1.0.3-6.fc10.i386
Mar 03 20:44:39 Updated: gvfs-obexftp-1.0.3-6.fc10.i386
Mar 03 20:44:39 Updated: gvfs-gphoto2-1.0.3-6.fc10.i386
Mar 03 20:44:40 Updated: audit-1.7.12-1.fc10.i386

I know this is not a yum bug, but which package broke win?
Comment 1 William Lovaton 2009-03-05 07:52:13 EST
I have the very same problem.  I applied updates yesterday and now wine refuse to take any input from the keyboard.  The mouse still works fine but not the keyboard.

This is really serious for me because I need TOAD to do Oracle development, but as the reporter said even notepad doesn't work.

This is a Fedora 10 system with official packages plus RPM Fusion.  The updated packages were:

Mar 04 08:48:32 Updated: gvfs-1.0.3-6.fc10.i386
Mar 04 08:48:33 Updated: audit-libs-1.7.12-1.fc10.i386
Mar 04 08:48:38 Updated: evolution-data-server-2.24.5-1.fc10.i386
Mar 04 08:48:39 Updated: SDL-1.2.13-7.fc10.i386
Mar 04 08:48:44 Updated: coreutils-6.12-19.fc10.i386
Mar 04 08:48:48 Updated: gtkhtml3-3.24.5-1.fc10.i386
Mar 04 08:49:55 Updated: evolution-2.24.5-1.fc10.i386
Mar 04 08:49:57 Updated: pciutils-libs-3.0.2-3.fc10.i386
Mar 04 08:49:57 Updated: 1:cups-libs-1.3.9-8.fc10.i386
Mar 04 08:49:59 Updated: mplayer-1.0-0.104.20090204svn.fc10.i386
Mar 04 08:50:00 Updated: linuxwacom-0.8.0.3-8.fc10.i386
Mar 04 08:50:02 Updated: libgxim-0.3.2-3.fc10.i386
Mar 04 08:50:04 Updated: anthy-9100h-1.fc10.i386
Mar 04 08:50:07 Updated: mplayer-gui-1.0-0.104.20090204svn.fc10.i386
Mar 04 08:50:17 Updated: 1:cups-1.3.9-8.fc10.i386
Mar 04 08:50:17 Updated: pciutils-3.0.2-3.fc10.i386
Mar 04 08:50:18 Updated: evolution-spamassassin-2.24.5-1.fc10.i386
Mar 04 08:50:26 Updated: evolution-exchange-2.24.5-1.fc10.i386
Mar 04 08:50:30 Updated: audit-1.7.12-1.fc10.i386
Mar 04 08:50:31 Updated: audit-libs-python-1.7.12-1.fc10.i386
Mar 04 08:50:31 Updated: gvfs-gphoto2-1.0.3-6.fc10.i386
Mar 04 08:50:31 Updated: gvfs-obexftp-1.0.3-6.fc10.i386
Mar 04 08:50:31 Updated: gvfs-smb-1.0.3-6.fc10.i386
Mar 04 08:50:32 Updated: gvfs-archive-1.0.3-6.fc10.i386
Mar 04 08:50:32 Updated: gvfs-fuse-1.0.3-6.fc10.i386
Mar 04 08:50:33 Updated: alsa-utils-1.0.19-2.fc10.i386
Mar 04 08:50:34 Updated: iok-1.3.1-1.fc10.i386
Mar 04 08:50:35 Updated: upstart-0.3.9-22.fc10.i386
Mar 04 08:50:35 Updated: xorg-x11-drv-vmmouse-12.6.3-3.fc10.i386
Mar 04 08:51:10 Updated: selinux-policy-3.5.13-46.fc10.noarch
Mar 04 08:51:12 Updated: kernel-firmware-2.6.27.19-170.2.35.fc10.noarch
Mar 04 08:51:18 Updated: kernel-headers-2.6.27.19-170.2.35.fc10.i386
Mar 04 08:52:54 Updated: selinux-policy-targeted-3.5.13-46.fc10.noarch
Mar 04 08:53:18 Updated: evolution-perl-2.24.5-1.fc10.i386
Mar 04 08:51:15 Installed: system-config-date-1.9.36-1.fc10.noarch
Mar 04 08:52:57 Installed: system-config-date-docs-1.0.5-1.fc10.noarch
Mar 04 08:53:18 Installed: kernel-2.6.27.19-170.2.35.fc10.i686

May be this is an Xorg issue.

This is really important to me, please help.
Comment 2 D Levin 2009-03-06 10:01:46 EST
May be fixed, check out
http://forums.fedoraforum.org/showthread.php?p=1178921
Comment 3 William Lovaton 2009-03-06 15:05:43 EST
And one of these updates fixed the problem:

Mar 06 14:41:19 Updated: libtalloc-1.2.0-27.fc10.i386
Mar 06 14:41:19 Updated: libtdb-1.1.1-27.fc10.i386
Mar 06 14:41:20 Updated: bluez-libs-4.30-2.fc10.i386
Mar 06 14:41:20 Updated: libcurl-7.19.4-1.fc10.i386
Mar 06 14:41:22 Updated: lshw-B.02.14-1.fc10.i386
Mar 06 14:41:23 Updated: fftw-3.2.1-1.fc10.i386
Mar 06 14:41:25 Updated: libgxim-0.3.2-4.fc10.i386
Mar 06 14:41:28 Updated: lshw-gui-B.02.14-1.fc10.i386
Mar 06 14:41:28 Updated: curl-7.19.4-1.fc10.i386
Mar 06 14:41:30 Updated: bluez-4.30-2.fc10.i386
Mar 06 14:41:30 Updated: bluez-cups-4.30-2.fc10.i386
Mar 06 14:41:30 Updated: bluez-alsa-4.30-2.fc10.i386
Mar 06 14:41:31 Updated: xorg-x11-drv-synaptics-0.15.2-4.fc10.i386
Mar 06 14:41:33 Updated: samba-winbind-3.2.8-0.27.fc10.i386
Mar 06 14:41:40 Updated: samba-common-3.2.8-0.27.fc10.i386
Mar 06 14:41:40 Updated: libsmbclient-3.2.8-0.27.fc10.i386
Comment 4 Jon Dufresne 2009-03-26 10:14:34 EDT
Thank you for the bug report. According to comment 3, this has been fixed so I am closing. If you still are experiencing the bug please reopen with new information.

Note You need to log in before you can comment on or make changes to this bug.