Bug 488400 - Evolution ignores /desktop/gnome/interface/gtk_key_theme
Evolution ignores /desktop/gnome/interface/gtk_key_theme
Status: CLOSED DUPLICATE of bug 473657
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-03 23:59 EST by Kevin L. Mitchell
Modified: 2009-03-04 05:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 05:04:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin L. Mitchell 2009-03-03 23:59:04 EST
Description of problem:

Evolution ignores the /desktop/gnome/interface/gtk_key_theme setting.  This has gotten worse--since installing Fedora Core 10, C-a and C-e were ignored (or rather bound to functions other than beginning of line and end of line), but C-k honored; now, with the most recent update to Evolution, C-k is also being ignored.

Version-Release number of selected component (if applicable):

evolution-2.24.5-1.fc10

How reproducible:

100%; quitting and restarting Evolution has no effect on whether it honors gtk_key_theme.

Steps to Reproduce:
1. Update to Evolution 2.24.5-1.fc10
2. Set /desktop/gnome/interface/gtk_key_theme to "Emacs"
3. Attempt to use emacs key bindings within the composer window.
  
Actual results:

C-a is bound to select-all; C-e appears to be bound to center-text; I have no idea what C-k is bound to.

Expected results:

C-a should be bound to beginning-of-line; C-e should be bound to end-of-line; C-k should be bound to delete remaining text on line; etc.

Additional info:
Comment 1 Milan Crha 2009-03-04 05:04:50 EST

*** This bug has been marked as a duplicate of bug 473657 ***

Note You need to log in before you can comment on or make changes to this bug.