This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 488422 - cernlib : Conflicts with other packages
cernlib : Conflicts with other packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cernlib (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 488423 488424 488426 488427
  Show dependency treegraph
 
Reported: 2009-03-04 04:32 EST by Michael Schwendt
Modified: 2009-03-30 16:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-30 16:26:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-03-04 04:32:20 EST
=> cernlib-2006-32.fc11.src.rpm
=> cernlib-2006-32.fc11.i586 in rawhide-development-i386
  File conflict with: cernlib-g77-2006-31.fc10.i386
     /usr/share/cernlib/2006/cojets.dat
     /usr/share/cernlib/2006/eurodec.dat
     /usr/share/cernlib/2006/isajet.dat
     /usr/share/cernlib/2006/xsneut95.dat

=> cernlib-2006-32.fc11.src.rpm
=> cernlib-devel-2006-32.fc11.i586 in rawhide-development-i386
  File conflict with: cernlib-g77-devel-2006-31.fc10.i386
     /usr/share/aclocal/cernlib.m4

=> cernlib-g77-2006-31.fc10.src.rpm
=> cernlib-g77-2006-31.fc10.i386 in rawhide-development-i386
  File conflict with: cernlib-2006-32.fc11.i586
     /usr/share/cernlib/2006/cojets.dat
     /usr/share/cernlib/2006/eurodec.dat
     /usr/share/cernlib/2006/isajet.dat
     /usr/share/cernlib/2006/xsneut95.dat

=> cernlib-g77-2006-31.fc10.src.rpm
=> cernlib-g77-devel-2006-31.fc10.i386 in rawhide-development-i386
  File conflict with: cernlib-devel-2006-32.fc11.i586
     /usr/share/aclocal/cernlib.m4

=> cernlib-g77-2006-31.fc10.src.rpm
=> cernlib-g77-utils-2006-31.fc10.i386 in rawhide-development-i386
  File conflict with: cernlib-utils-2006-32.fc11.i586
     /usr/share/man/man1/cernlib-static.1.gz
     /usr/share/man/man1/cernlib.1.gz

=> cernlib-g77-2006-31.fc10.src.rpm
=> cernlib-packlib-2006-31.fc10.i386 in rawhide-development-i386
  File conflict with: cernlib-packlib-gfortran-2006-32.fc11.i586
     /usr/share/X11/app-defaults/KXterm
     /usr/share/man/man1/dzeX11.1.gz
     /usr/share/man/man1/dzedit.1.gz
     /usr/share/man/man1/kuesvr.1.gz
     /usr/share/man/man1/kxterm.1.gz
     /usr/share/man/man1/zftp.1.gz
     /usr/share/man/man8/pawserv.8.gz
     /usr/share/man/man8/zserv.8.gz
     /usr/share/pixmaps/kxterm32x32.xpm
     /usr/share/pixmaps/kxterm48x48.xpm

=> cernlib-g77-2006-31.fc10.src.rpm
=> cernlib-packlib-g77-2006-31.fc10.i386 in rawhide-development-i386
  File conflict with: cernlib-packlib-gfortran-2006-32.fc11.i586
     /usr/share/X11/app-defaults/KXterm
     /usr/share/man/man1/dzeX11.1.gz
     /usr/share/man/man1/dzedit.1.gz
     /usr/share/man/man1/kuesvr.1.gz
     /usr/share/man/man1/kxterm.1.gz
     /usr/share/man/man1/zftp.1.gz
     /usr/share/man/man8/pawserv.8.gz
     /usr/share/man/man8/zserv.8.gz
     /usr/share/pixmaps/kxterm32x32.xpm
     /usr/share/pixmaps/kxterm48x48.xpm

=> cernlib-2006-32.fc11.src.rpm
=> cernlib-packlib-gfortran-2006-32.fc11.i586 in rawhide-development-i386
  File conflict with: cernlib-packlib-2006-31.fc10.i386
     /usr/share/X11/app-defaults/KXterm
     /usr/share/man/man1/dzeX11.1.gz
     /usr/share/man/man1/dzedit.1.gz
     /usr/share/man/man1/kuesvr.1.gz
     /usr/share/man/man1/kxterm.1.gz
     /usr/share/man/man1/zftp.1.gz
     /usr/share/man/man8/pawserv.8.gz
     /usr/share/man/man8/zserv.8.gz
     /usr/share/pixmaps/kxterm32x32.xpm
     /usr/share/pixmaps/kxterm48x48.xpm
  File conflict with: cernlib-packlib-g77-2006-31.fc10.i386
     /usr/share/X11/app-defaults/KXterm
     /usr/share/man/man1/dzeX11.1.gz
     /usr/share/man/man1/dzedit.1.gz
     /usr/share/man/man1/kuesvr.1.gz
     /usr/share/man/man1/kxterm.1.gz
     /usr/share/man/man1/zftp.1.gz
     /usr/share/man/man8/pawserv.8.gz
     /usr/share/man/man8/zserv.8.gz
     /usr/share/pixmaps/kxterm32x32.xpm
     /usr/share/pixmaps/kxterm48x48.xpm

=> cernlib-2006-32.fc11.src.rpm
=> cernlib-utils-2006-32.fc11.i586 in rawhide-development-i386
  File conflict with: cernlib-g77-utils-2006-31.fc10.i386
     /usr/share/man/man1/cernlib-static.1.gz
     /usr/share/man/man1/cernlib.1.gz
Comment 1 Gwyn Ciesla 2009-03-24 15:19:11 EDT
cernlib-g77-2006-32 is now built successfully in rawhide.  Patrice, I seem to recall us having a conversation about the best way to resolve this and the other conflict bugs, but I can't find it.  Can you point me in the right direction or repost here?
Comment 2 Patrice Dumas 2009-03-24 18:29:39 EDT
A rebuild should be enough to fix the conflict, since there is no real conflict, the conflict was caused by a change in rpm sums.
Comment 3 Michael Schwendt 2009-03-25 03:40:33 EDT
Really? Haven't you changed anything else? Such as package names? I wonder why the i586 rebuilds have not pruned the older i386 builds? Could be an indication that "Obsoletes" are missing here, because Rawhide only keeps the latest build.
Comment 4 Patrice Dumas 2009-03-25 04:47:15 EDT
Unless I am wrong the cernlib-packlib package is a subpackage of cernlib-g77, like all the other packages conflicting, so all the .i386 packages come from cernlib-g77 that was not rebuilt previously.
Comment 5 Michael Schwendt 2009-03-25 05:25:32 EDT
Ah, I see the pattern in these reports. All the release -31 packages come from the cernlib-g77-2006-31.fc10.src.rpm
Comment 6 Gwyn Ciesla 2009-03-25 07:58:28 EDT
Then, since the rebuild was successful, I should close these, no?  Michael, can you re-run whatever you ran to detect these conflicts, in order to verify this?
Comment 7 Gwyn Ciesla 2009-03-30 14:27:20 EDT
Ping?  And wither 487989?

Note You need to log in before you can comment on or make changes to this bug.