Bug 488436 - maven completely broken on f10
maven completely broken on f10
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: maven2 (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 05:40 EST by Christoph Höger
Modified: 2009-03-04 09:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 09:27:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of mvn archetype:create (6.81 KB, application/octet-stream)
2009-03-04 05:40 EST, Christoph Höger
no flags Details

  None (edit)
Description Christoph Höger 2009-03-04 05:40:55 EST
Created attachment 333988 [details]
output of mvn archetype:create

So, this is a weird one. I have a working (at least I think so) maven2 installation on my f9 notebook. As I wanted to build my projects on my f10 desktop, I encounter some _real_ weird problems, it seems like commandline parsing is somehow wrecked. 

Version-Release number of selected component (if applicable):
[choeger@choeger5 maventest]$ rpm -qa | grep maven
maven-shared-file-management-1.0-4.6.fc10.i386
maven-surefire-booter-1.5.3-2.8.fc10.i386
maven-wagon-1.0-0.1.a5.3.4.fc10.noarch
maven2-manual-2.0.4-10.15.fc10.i386
maven2-plugin-eclipse-2.0.4-10.15.fc10.i386
maven-scm-1.0-0.2.b3.1.6.fc10.i386
maven2-plugin-surefire-2.0.4-10.15.fc10.i386
maven2-2.0.4-10.15.fc10.i386
maven-shared-plugin-testing-harness-1.0-4.6.fc10.i386
maven2-plugin-resources-2.0.4-10.15.fc10.i386
maven-shared-1.0-4.6.fc10.i386
maven2-common-poms-1.0-4.4.fc10.noarch
maven-doxia-1.0-0.2.a7.2.10.fc10.i386
maven-surefire-1.5.3-2.8.fc10.i386
maven2-plugin-surefire-report-2.0.4-10.15.fc10.i386
maven-jxr-1.0-2.8.fc10.i386


How reproducible:
always

Steps to Reproduce:
1. rm -rf ~/.m2
2. mvn archetype:create -DgroupId=com.example -DartifactId=myApp

Actual results:
see attached log, basically you get:

Invalid task 'artifactId=myApp': you must specify a valid lifecycle phase, or a goal in the format plugin:goal or pluginGroupId:pluginArtifactId:pluginVersion:goal


Expected results:
you should see a simple maven project

Additional info:
This problem also occurs on mvn install:install-file, note that install-plugin was even not discovered by mvn help:describe -Dplugin=install before copying .m2 from a sane installation.
Comment 1 Deepak Bhole 2009-03-04 09:27:36 EST
The problem is with jakarta-commons-cli. I just requested an update for F10. In the mean time, you can try installing it from here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=90241

Feel free to re-open if the problem persists. The update should be hitting F10 stable soon.

Note You need to log in before you can comment on or make changes to this bug.