Bug 488465 - yelp crash (symbol lookup error)
yelp crash (symbol lookup error)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 09:19 EST by Sergey
Modified: 2009-03-04 11:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 11:25:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sergey 2009-03-04 09:19:19 EST
Description of problem:
yelp crash


Version-Release number of selected component (if applicable):
yelp-2.24.0-5.fc10.x86_64
libxslt-1.1.24-2.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. yelp

Actual results:
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
Error: Malformed line (no section).  Ignoring entry
Error: Malformed line (no section).  Ignoring entry
Error: Malformed line (no section).  Ignoring entry
Error: Malformed line (no filename).  Ignoring entry
yelp: symbol lookup error: /usr/lib64/libxslt.so.1: undefined symbol: xmlXPathCompiledEvalToBoolean


Expected results:
help system started
Comment 1 Matthew Barnes 2009-03-04 10:21:32 EST
xmlXPathCompiledEvalToBoolean comes from libxml2 and has been there since version 2.6.27 (released Oct 2006).  What version of libxml2 do you have?
Comment 2 Sergey 2009-03-04 10:26:15 EST
libxml2-2.7.3-1.fc10.x86_64
Comment 3 Sergey 2009-03-04 10:28:41 EST
Oops

ldd /usr/bin/yelp
	libxml2.so.2 => /usr/lib/vmware-vix/lib/libxml2.so.2
Comment 4 Matthew Barnes 2009-03-04 10:56:38 EST
So that looks like an environment configuration issue on your system.

How do you want to proceed?  Close as NOTABUG?
Comment 5 Sergey 2009-03-04 11:20:20 EST
yes, close it. Thanks and sorry.

Note You need to log in before you can comment on or make changes to this bug.