Bug 488564 - repo --mirrorlist in kickstart is broken
repo --mirrorlist in kickstart is broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 15:33 EST by yuri
Modified: 2009-04-06 10:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 10:33:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (56.66 KB, text/plain)
2009-03-04 15:33 EST, yuri
no flags Details

  None (edit)
Description yuri 2009-03-04 15:33:43 EST
Created attachment 334054 [details]
anaconda.log

Description of problem:
When repo --mirrorlist=... is specified in kickstart, installation dies.

Version-Release number of selected component (if applicable):
Everything that comes with F10 (anaconda 11.4.1.62)

How reproducible:
Every time, just use the kickstart file provided

Steps to Reproduce:
1. network install by kickstart
2.
3.
  
Actual results:
anaconda 11.4.1.62 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 574, in _replace_and_check_url
    if url[-1] != '/':
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 538, in _baseurlSetup
    self.baseurl = self._replace_and_check_url(self.baseurl)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 593, in _geturls
    self._baseurlSetup()
(see full version attached)


Expected results:
Expected to see mirrorlist option working.

Additional info:
It seems that if addition repositories are specified with repo, but baseurl is not specified (instead mirrorlist is used), parsing of baseurl fails and everything dies.
Comment 1 Garrett Holmstrom 2009-03-12 14:08:54 EDT
I'm seeing the same problem in F10 as well, with the same traceback.  The offending lines for me are:

repo --name=rpmfusion-free --mirrorlist=http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-10&arch=i386
repo --name=rpmfusion-nonfree --mirrorlist=http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-10&arch=i386
repo --name=rpmfusion-free-updates --mirrorlist=http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-updates-released-10&arch=i386
repo --name=rpmfusion-nonfree-updates --mirrorlist=http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-updates-released-10&arch=i386
repo --name=everything --mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-10&arch=i386
repo --name=fedora-updates --mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f10&arch=i386
Comment 2 Chris Lumens 2009-03-31 13:56:56 EDT
A quick test with these same lines in F11 Beta shows this is no longer a problem.  Can you please also test and verify that you are not seeing this problem anymore?  Thanks.
Comment 3 Garrett Holmstrom 2009-04-03 18:21:47 EDT
It looks like i386 images failed to build today, but everything looks like it worked using the images I had from March 27th.
Comment 4 Chris Lumens 2009-04-06 10:33:54 EDT
Okay, thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.