Bug 488655 - firstrun url is incorrect
firstrun url is incorrect
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 22:05 EST by Jerry Amundson
Modified: 2009-04-13 12:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 12:48:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry Amundson 2009-03-04 22:05:49 EST
Description of problem:
First run of firefox returns 404.

Version-Release number of selected component (if applicable):
firefox-3.1-0.7.beta2.fc11.i586

How reproducible:
Only on user's first run of FF.

Steps to Reproduce:
1.install FF
2.login 
3.run FF
  
Actual results:
404: File Not Found

/projects/firefox/3.1b2/firstrun/

We are sorry, the file you requested could not be found.

Expected results:
Welcome page, e.g. http://www.mozilla.com/en-US/firefox/3.1b2/firstrun/

Additional info:
Looks like /usr/lib/firefox-3.1b2/defaults/preferences/firefox-branding.js:
pref("startup.homepage_welcome_url","http://www.mozilla.org/projects/%APP%/%VERSION%/firstrun/");
should be like
pref("http://www.mozilla.org/%general.useragent.locale%/%APP%/%VERSION%/firstrun/");
Comment 1 Jerry Amundson 2009-03-04 22:13:30 EST
(In reply to comment #0)
> pref("http://www.mozilla.org/%general.useragent.locale%/%APP%/%VERSION%/firstrun/");

arrgh, clicked commit too soon, but I don't know the exact pref anyway... just "startup.homepage_welcome_url" should have been the first param above, of course.
Comment 2 Matěj Cepl 2009-03-05 03:29:25 EST
Yes, firstrun URL doesn't work in all beta versions of Firefox. It will get fixed in the release of firefox. Nothing for us to fix.
Comment 3 Christopher Aillon 2009-03-05 11:26:46 EST
Actually, I used to think that it's not our bug since I thought the page just didn't exist, but the reporter's comments lead me to believe otherwise.  We should figure out why it's not loading the en-US page which _does_ exist.  http://www.mozilla.com/en-US/firefox/3.1b2/firstrun/

Do other locales have a working firstrun page?
Comment 4 Jerry Amundson 2009-03-05 13:56:35 EST
(In reply to comment #3)
> Actually, I used to think that it's not our bug since I thought the page just
> didn't exist, but the reporter's comments lead me to believe otherwise.  We
> should figure out why it's not loading the en-US page which _does_ exist. 
> http://www.mozilla.com/en-US/firefox/3.1b2/firstrun/
> 
> Do other locales have a working firstrun page?  

They seem to exist, but either re-direct to the en-US page, or to an error document, or not respond. For example:
http://fy-NL.www.mozilla.com/fy-NL/firefox/3.1b2/firstrun/

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Martin Stransky 2009-03-25 07:45:44 EDT
http://www.mozilla.com/en-US/firefox/3.1b1/firstrun/
http://www.mozilla.com/en-US/firefox/3.1b2/firstrun/
http://www.mozilla.com/en-US/firefox/3.1b3/firstrun/

All pages exist but the latest one were created a few days after b3 release. Really looks like mozilla bug.
Comment 6 Jerry Amundson 2009-03-25 09:22:53 EDT
(In reply to comment #5)
> http://www.mozilla.com/en-US/firefox/3.1b1/firstrun/
> http://www.mozilla.com/en-US/firefox/3.1b2/firstrun/
> http://www.mozilla.com/en-US/firefox/3.1b3/firstrun/
> 
> All pages exist but the latest one were created a few days after b3 release.
> Really looks like mozilla bug.  

Fine, but the url code is still incorrect. Please read the Description.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Martin Stransky 2009-03-25 09:51:51 EDT
I see. The current (incorrect) firstrun page is:

http://www.mozilla.org/projects/firefox/3.1b3/firstrun/

but we want to change it to:

http://www.mozilla.com/en-US/firefox/3.1b3/firstrun/

Note You need to log in before you can comment on or make changes to this bug.