Bug 488728 - Backup of lvm metadata on remote nodes doesn't work
Backup of lvm metadata on remote nodes doesn't work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Milan Broz
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 09:22 EST by Milan Broz
Modified: 2013-02-28 23:07 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:57:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed (not final) patch... (6.96 KB, patch)
2009-03-05 09:25 EST, Milan Broz
no flags Details | Diff

  None (edit)
Description Milan Broz 2009-03-05 09:22:54 EST
Clvmd should try to backup metadata on unlocg_vg event.

Currently the remote metadata backup doesn't work,
because we added
	if (clvmd_cmd == CLVMD_CMD_LOCK_VG &&
	   ((flags & LCK_TYPE_MASK) == LCK_UNLOCK) &&
           (flags & LCK_CLUSTER_VG)) {
		... call the remote backup command

LCK_CLUSTER_VG is never set during LCK_UNLOCK,
unlock_vg() takes only vgname as argument and cannot
distinguish if vg is clustered, leaving flag unset
(that flag is set only if locking LV).
Comment 1 Milan Broz 2009-03-05 09:25:20 EST
Created attachment 334131 [details]
Proposed (not final) patch...

Proposed (not final) patch...
Comment 3 Milan Broz 2009-04-22 06:28:22 EDT
fixed upstream -> POST
Comment 4 Milan Broz 2009-05-21 05:24:22 EDT
Fix in version lvm2-cluster-2.02.46-1.el5.
Comment 7 errata-xmlrpc 2009-09-02 07:57:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1394.html

Note You need to log in before you can comment on or make changes to this bug.