Bug 488770 - pa erroneously selects digital output as standard output (thus no sound via internal speakers)
pa erroneously selects digital output as standard output (thus no sound via i...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 12:40 EST by Felix Kaechele
Modified: 2009-03-19 08:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 08:03:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshal of my computer (148.48 KB, text/plain)
2009-03-05 12:40 EST, Felix Kaechele
no flags Details

  None (edit)
Description Felix Kaechele 2009-03-05 12:40:52 EST
Created attachment 334162 [details]
lshal of my computer

Description of problem:
PulseAudio selects the digital output of the sound card instead of the analog output. However the internal speakers of my notebook are only connected to the analog output. This happened for the first time after I undocked my laptop with the "Undock" button on the Dock (Lenovo ThinkPad T61p with Advanced Mini Dock)

Version-Release number of selected component (if applicable):
pulseaudio-libs-zeroconf-0.9.15-3.test5.fc11.x86_64
pulseaudio-module-x11-0.9.15-3.test5.fc11.x86_64
pulseaudio-libs-0.9.15-3.test5.fc11.x86_64
pulseaudio-module-zeroconf-0.9.15-3.test5.fc11.x86_64
pulseaudio-utils-0.9.15-3.test5.fc11.x86_64
pulseaudio-esound-compat-0.9.15-3.test5.fc11.x86_64
pulseaudio-libs-glib2-0.9.15-3.test5.fc11.x86_64
pulseaudio-module-gconf-0.9.15-3.test5.fc11.x86_64
alsa-plugins-pulseaudio-1.0.18-3.fc11.x86_64
pulseaudio-0.9.15-3.test5.fc11.x86_64
pulseaudio-module-jack-0.9.15-3.test5.fc11.x86_64
  
Actual results:
no sound via internal speakers

Expected results:
sound via internal speakers

Additional info:
Alsa-Info:
http://www.alsa-project.org/db/?f=21be9f747fba3888fe7ccbb1441bb3d63376497d
Comment 1 Felix Kaechele 2009-03-07 13:23:42 EST
After the update today I found the "Configuration" tab in the gnome-mixer applet. I changed the profile to "Output Analog Stereo + Input Analog Stereo". No it seems to be fixed. But i'll have an eye if it switches again if I undock.
Comment 2 Felix Kaechele 2009-03-07 13:25:08 EST
Sorry, I meant pavucontrol.
Comment 3 Lennart Poettering 2009-03-19 08:03:06 EDT
Probably some application blocked access to the analog audio, PA then tries to find an alternative profile to switch to which is usually SPDIF. Once you change back PA will remember.

Note You need to log in before you can comment on or make changes to this bug.