This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 488786 - eclipse-ecj OSGI requires
eclipse-ecj OSGI requires
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 13:33 EST by Alphonse Van Assche
Modified: 2009-03-12 03:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 14:11:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alphonse Van Assche 2009-03-05 13:33:37 EST
Description of problem:
To be able to enable osgideps script in eclipse.spec, ecj sub-package need some changes. The problem is that this package symlink to jdt core jar and that jar requires follow OSGI bundles:

osgi(org.eclipse.core.resources) >= 3.3.0
osgi(org.eclipse.core.runtime) >= 3.3.0
osgi(org.eclipse.core.filesystem) >= 1.0.0
osgi(org.eclipse.text) >= 3.1.0
osgi(org.eclipse.team.core) >= 3.1.0

All these bundles are provided by the rcp sub-package but I'm not sure that gcj guys will such dependencies.

Regards,
Alphonse
Comment 1 Andrew Overholt 2009-03-05 15:15:46 EST
Yeah, if we try to honour the real OSGi dependencies of jdt.core then we'll have to have eclipse-ecj be on top of eclipse-rcp.  java-gcj-compat requiring that is a non-starter.  I think this makes the need for a separate ecj package more pressing.
Comment 2 Alphonse Van Assche 2009-03-05 15:39:44 EST
Yes, a separate ecj package seem to be the clean way to fix this.
Comment 3 Andrew Overholt 2009-03-11 14:11:14 EDT
A separate ecj package is now in rawhide and will be in the F-11 beta.
Comment 4 Alphonse Van Assche 2009-03-12 03:31:07 EDT
Many thanks

Note You need to log in before you can comment on or make changes to this bug.