Bug 488796 - OOo-writer does not check spelling in all installed languages
OOo-writer does not check spelling in all installed languages
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 14:12 EST by Peter Gückel
Modified: 2009-03-05 15:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 15:01:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 98867 None None None Never

  None (edit)
Description Peter Gückel 2009-03-05 14:12:36 EST
Description of problem:
Under language settings, there used to be a box to make openoffice check the spelling in all installed languages. This has disappeared since a few months.

Version-Release number of selected component (if applicable):
3.1.0-3.3.fc11.i586

How reproducible:
Try to have OOo-writer check the spelling in a multi-language file: all non-English words will be flagged as errors, even though these other languages are installed.

Steps to Reproduce:
1. Write a multilanguage file
2. Check the spelling, or just observe the red underlines under all non-English words
3. Once be able to check the document in English, but not in the other languages, hence there could be errors
  
Actual results:
It is not possible, as it used to be, to check the spelling in all installed languages

Expected results:
The spell checkeing should use all available dictionaries for all installed languages, given that one has selected this option in the setup.

Additional info:
Comment 1 Caolan McNamara 2009-03-05 15:01:23 EST
See http://specs.openoffice.org/appwide/linguistic/Spelling_and_Grammar.odt
"Remove Check in all languages from Options list box"
it was done deliberately (http://qa.openoffice.org/issues/show_bug.cgi?id=98867)

The "right" way has always been to mark the words as their correct language so they get checked against the matching dictionary. I don't know though what the rationale is for removing the "I don't care, and check everything in all dictionaries anyway" option. Either way, its not a specific Fedora bug.

Note You need to log in before you can comment on or make changes to this bug.