This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 488808 - RPM contains just a few files
RPM contains just a few files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: FlightGear (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Fabrice Bellet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 14:57 EST by Wolfram Wagner
Modified: 2009-06-29 15:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 15:02:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wolfram Wagner 2009-03-05 14:57:17 EST
Description of problem:
I report what I have seen in RPM metadata in smart:

The FlightGear RPM is normaly about 150 MB in size. Currently it is down to 2!
It contains only 

/usr/bin/al-info
/usr/share/applications/est-epsilon
/usr/share/doc/FlightGear-1.0.0/fgfs-wrapper
/usr/share/doc/fgfs
/usr/share/icons/hicolor/128x128/apps/fgjs
/usr/share/icons/hicolor/16x16/apps/gl-info
/usr/share/icons/hicolor/32x32/apps/js_demo
/usr/share/icons/hicolor/48x48/apps/metar
/usr/share/icons/hicolor/64x64/apps/terrasync
/usr/share/man/man1/yasim

If this is right, then the last build has failed.Why don't we step to the latest version 1.5, when you repair it? 

Thank you!
Wolfram
Comment 1 Andre Robatino 2009-03-06 06:06:43 EST
Maybe the bulk of the package was moved to the fgfs-base package, which is a dependency for FlightGear?  (I've never installed FlightGear before but it looks that way.)

================================================================================
 Package            Arch           Version                 Repository      Size
================================================================================
Installing:
 FlightGear         x86_64         1.0.0-4.fc10            fedora         2.3 M
Installing for dependencies:
 SimGear            x86_64         1.0.0-5.fc10            fedora         673 k
 fgfs-base          noarch         1.0.0-1.fc9             fedora         202 M
 freealut           x86_64         1.1.0-6.fc9             fedora          41 k
 plib               x86_64         1.8.5-1.fc10            fedora         633 k

Transaction Summary
================================================================================
Install      5 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 206 M
Is this ok [y/N]:
Comment 2 Fabrice Bellet 2009-03-06 08:00:47 EST
Yes, all FlightGear data files are in the fgfs-base package.

Moreover, your filelist looks strange to me, because files and directory don't match with the content of the real fedora package. For example, fgfs-wrapper is in /usr/bin, not in /usr/share/doc/FlightGear-1.0.0. See http://fr2.rpmfind.net//linux/RPM/fedora/10/i386/FlightGear-1.0.0-4.fc10.i386.html. This is maybe a bug in smart.

Finally, the latest version of FlightGear (1.9.1) is available in rawhide, and will be shipped in Fedora 11.
Comment 3 Wolfram Wagner 2009-06-29 15:02:12 EDT
Thank you. Works for me now.

Note You need to log in before you can comment on or make changes to this bug.