This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 488811 - general input/output error when opening pdf documents
general input/output error when opening pdf documents
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 15:03 EST by Martin Jürgens
Modified: 2009-03-19 09:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 09:42:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Jürgens 2009-03-05 15:03:14 EST
Description of problem:
When I try to open any PDF document, I get a

general input/output error

Version-Release number of selected component (if applicable):
openoffice.org-pdfimport-3.0.1-15.2.fc10.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. Open any PDF document
2.
3.
  
Actual results:
general input/output error

Expected results:
should import the pdf file

Additional info:
when i remove openoffice.org-pdfimport-3.0.1-15.2.fc10.i386.rpm and install the pdfimport extension from the openoffice website, everything works fine.
Comment 1 Caolan McNamara 2009-03-06 04:28:34 EST
Hmm, I just freshly installed openoffice.org-draw and openoffice.org-pdfimport and opened a random .pdf and it imported just fine with 3.0.1-15.2.fc10

Maybe attach a sample .pdf just in case there is something special about them. But more likely is that something got cocked up with the pdfimport extension registration at install time rather than being a problem with the extension itself, i.e. it might have been that re-installing the fedora one would have worked at well.
Comment 2 Martin Jürgens 2009-03-06 07:01:39 EST
I have reinstalled the pdf extension, but still no go. I will attach a pdf example file. Any way to debug that problem?
Comment 3 Martin Jürgens 2009-03-06 07:02:58 EST
well , that pdf for example http://www.bundestag.de/parlament/funktion/gesetze/gg_jan2007.pdf
Comment 4 Caolan McNamara 2009-03-06 07:19:10 EST
Hmm, imports for me, slowly, launched from e.g. "oodraw gg_jan2007.pdf" but it does work.

What's the output of

unopkg list --shared
and 
unopkg list 

and is "PDF Import Extension 0.3.2" listed in tools->extension manager ?
Comment 5 Martin Jürgens 2009-03-06 07:32:04 EST
unopkg list --shared:
http://pastebin.com/f13b6e6ed

$ unopkg list 
all deployed user packages:
<none>

Yes, the extension is listed in the extension manager.
Comment 6 Caolan McNamara 2009-03-06 07:51:37 EST
Config looks fine anyway. Should be no particular reason why the fedora one fails while the "vanilla" one works. I assume that e.g. evince works fine on opening the document for you as well, i.e. there's no bustage of the shared libpoppler.
Comment 7 Martin Jürgens 2009-03-06 08:09:18 EST
maybe i have a buggy poppler version?

here, poppler-0.8.7-5.fc10.i386 is installed.
Comment 8 Caolan McNamara 2009-03-09 11:01:48 EDT
"maybe i have a buggy poppler version?

here, poppler-0.8.7-5.fc10.i386 is installed."

Does evince works fine on opening the .pdf ? If it does then poppler is likely perfectly fine.
Comment 9 Martin Jürgens 2009-03-09 11:22:08 EDT
Evince works perfectly fine..
Comment 10 Caolan McNamara 2009-03-18 08:39:46 EDT
caolanm->dtardon: Can you reproduce any similiar problems with the bundled pdfimport extension ?
Comment 11 David Tardon 2009-03-18 10:53:04 EDT
No chance. Could it be i386 specific?
Comment 12 Caolan McNamara 2009-03-18 10:57:43 EDT
Can't be i386 specific, my F-10 box is i386. I can't imagine anything that would be affected by e.g. GNOME vs KDE, but its under GNOME that everything got checked.
Comment 13 Caolan McNamara 2009-03-19 09:42:03 EDT
Can't reproduce :-(

Note You need to log in before you can comment on or make changes to this bug.