Bug 488859 - [StorageRewrite] TypeError: argument 2 must be string, not None
[StorageRewrite] TypeError: argument 2 must be string, not None
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
StorageRewrite anaconda_trace_hash:5a...
:
: 488952 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 18:30 EST by James Laska
Modified: 2013-09-02 02:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 09:48:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (86.49 KB, text/plain)
2009-03-05 18:30 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2009-03-05 18:30:46 EST
The following was filed automatically by anaconda:
anaconda 11.5.0.24 exception report
Traceback (most recent call first):
  File "/tmp/updates/storage/devicelibs/crypto.py", line 65, in luks_format
    rc = cs.luksFormat(device = device, cipher = cipher, keysize = key_size, keyfile = key_file)
  File "/tmp/updates/storage/formats/luks.py", line 143, in create
    key_size=self.key_size)
  File "/tmp/updates/storage/deviceaction.py", line 267, in execute
    options=self.device.formatArgs)
  File "/tmp/updates/storage/devicetree.py", line 427, in processActions
    action.execute(intf=self.intf)
  File "/tmp/updates/storage/__init__.py", line 181, in doIt
    self.devicetree.processActions()
  File "/tmp/updates/packages.py", line 114, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
TypeError: argument 2 must be string, not None
Comment 1 James Laska 2009-03-05 18:30:51 EST
Created attachment 334234 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-03-05 18:32:20 EST
Test case: encrypted autopartition using single disk
Comment 3 Radek Vykydal 2009-03-06 09:27:49 EST
*** Bug 488952 has been marked as a duplicate of this bug. ***
Comment 4 Radek Vykydal 2009-03-06 09:36:20 EST
Martin Sivak fixed this in pycryptsetup 0.0.7
(which was present in updates.img used in Fedora Test Day Thu 5,
but due to path issues, anaconda loaded module from install.img)
and with commit 0b65aca74899a558d14d1e305bb98380be185dfc.
Comment 5 Chris Lumens 2009-03-06 11:37:36 EST
Putting into MODIFIED for now.  We can close it out once we've verified it works with the latest pycryptsetup.
Comment 6 James Laska 2009-04-14 09:48:01 EDT
Not seeing this exact traceback anymore

Note You need to log in before you can comment on or make changes to this bug.