Bug 488889 - mcstrans does not generate its pidfile
mcstrans does not generate its pidfile
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mcstrans (Show other bugs)
5.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
BaseOS QE
:
Depends On:
Blocks: 578169
  Show dependency treegraph
 
Reported: 2009-03-05 23:14 EST by Christian Unger
Modified: 2012-01-17 12:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 578169 (view as bug list)
Environment:
Last Closed: 2012-01-17 12:22:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Unger 2009-03-05 23:14:02 EST
Description of problem:
mcstrans does not generate a pid (the startup script refers to /var/run/mcstransd.pid

Version-Release number of selected component (if applicable):
Name        : mcstrans                     Relocations: (not relocatable)
Version     : 0.2.11                            Vendor: Red Hat, Inc.
Release     : 3.el5                         Build Date: Fri 21 Nov 2008 06:46:04 AM EST

How reproducible:
Very, just start / restart the daemon

Steps to Reproduce:
1. service mcstrans restart
2. ls `grep pidfile /etc/init.d/mcstrans | cut -d ':' -f 2`
  
Actual results:
ls: /var/run/mcstransd.pid: No such file or directory


Expected results:
/var/run/mcstransd.pid

(preferably one that contains the pid)

Additional info:
Comment 2 Peter Bieringer 2010-08-03 04:17:26 EDT
Still not fixed for mcstrans-0.2.11-3.el5, which results that this process can't be monitored by "monit". Note that if this process suddenly dies (which happened on some of my systems), cron jobs are no longer executed.

Jul 30 09:01:01 system crond[15748]: (root) CMD (run-parts /etc/cron.hourly)


Jul 30 09:01:20 system kernel: mcstransd/25176: potentially unexpected fatal signal 9.
Jul 30 09:01:20 system kernel: code at 0082f402: c3 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90
Jul 30 09:01:20 system kernel:
Jul 30 09:01:20 system kernel: Pid: 25176, comm:            mcstransd
Jul 30 09:01:20 system kernel: EIP: 0073:[<0082f402>] CPU: 0
Jul 30 09:01:20 system kernel: EIP is at 0x82f402
Jul 30 09:01:20 system kernel: ESP: 007b:bfa7a674 EFLAGS: 00200246    Tainted: G       (2.6.18-194.8.1.el5 #1)
Jul 30 09:01:20 system kernel: EAX: 00000001 EBX: 085bb4b8 ECX: 00000001 EDX: ffffffff
Jul 30 09:01:20 system kernel: ESI: 085bb4c0 EDI: 00f21ff4 EBP: bfa7a688 DS: 007b ES: 007b
Jul 30 09:01:20 system kernel: CR0: 8005003b CR2: 001cff70 CR3: 02497000 CR4: 000006d0

Jul 30 09:05:01 system crond[16101]: CRON (*system*) ERROR:Could not set exec context to user_u:system_r:unconfined_t for user
Jul 30 09:05:01 system crond[16101]: CRON (root) ERROR: failed to change SELinux context
Jul 30 09:05:01 system crond[16101]: CRON (root) ERROR: cannot set security context

Just note that I still have no idea, why mcstransd died, but if this stays undetected, cron is no longer working well.
Comment 3 Peter Bieringer 2010-08-03 04:22:05 EDT
Filed service request: 2046002
Comment 4 Daniel Walsh 2010-08-03 09:54:59 EDT
mcsctrans should not be required for any non MLS machine.    I think you are seeing a different problem.  I would just shut down mcstrans and run without it, as is done in RHEL6.  Your jobs should work fine.
Comment 5 Jeremy West 2012-01-17 12:22:50 EST
I'm going to close this bug out since there's been no update back on this for over a year now.  Please feel free to reopen this bug if additional feedback becomes available.

Note You need to log in before you can comment on or make changes to this bug.