Bug 488946 - Anaconda can't mount my filesystems from fstab when upgrading to rawhide
Anaconda can't mount my filesystems from fstab when upgrading to rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 07:12 EST by Espen Stefansen
Modified: 2009-03-10 11:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-10 11:51:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (11.30 KB, text/plain)
2009-03-06 18:54 EST, Espen Stefansen
no flags Details
storage.log (22.66 KB, text/plain)
2009-03-06 18:54 EST, Espen Stefansen
no flags Details
fstab (1.06 KB, text/plain)
2009-03-06 18:56 EST, Espen Stefansen
no flags Details

  None (edit)
Description Espen Stefansen 2009-03-06 07:12:19 EST
Description of problem:
I used preupgrade to upgrade my computer from f10 to the latest rawhide. After it had downloaded all the files and rebooted, anaconda searched for storage devices. It then said "One or more of the file systems listed in the /etc/fstab on your Linux system cannot be mounted. Please fix this problem and try to upgrade again.". 

My fstab should be just fine, since it works in f10. All devices are ext3 and recognised with UUID. I also looked in the logs, but cound't find any error relating to this. According to the logs, it found all my drives and what filesystem they had.

Let me know if there are any logs you might need.

Version-Release number of selected component (if applicable):
anaconda-11.5.0.25-1.i586.rpm

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2009-03-06 11:39:31 EST
What does your /etc/fstab look like?  Can you also run anaconda to this point again, switch to tty2, grab /tmp/anaconda.log and /tmp/storage.log, and attach them to this bug report?  Thanks.
Comment 2 Espen Stefansen 2009-03-06 18:54:23 EST
Created attachment 334361 [details]
anaconda.log
Comment 3 Espen Stefansen 2009-03-06 18:54:53 EST
Created attachment 334362 [details]
storage.log
Comment 4 Espen Stefansen 2009-03-06 18:56:47 EST
Created attachment 334363 [details]
fstab
Comment 5 David Lehman 2009-03-10 11:51:27 EDT
This should be fixed in anaconda-11.5.0.26, which is in today's rawhide. Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.