Bug 488948 - libopensync-plugin-syncml not installable
libopensync-plugin-syncml not installable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libopensync-plugin-syncml (Show other bugs)
rawhide
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Felix Kaechele
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 08:00 EST by Ruben Vermeersch
Modified: 2009-04-11 17:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-11 17:57:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruben Vermeersch 2009-03-06 08:00:34 EST
I am unable to install libopensync-plugin-syncml due to a missing dependency:

$ sudo yum install libopensync-plugin-syncml.i386 
[sudo] password for ruben: 
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package libopensync-plugin-syncml.i386 0:0.35-4.fc10 set to be updated
--> Processing Dependency: libsyncml.so.0 for package: libopensync-plugin-syncml
--> Processing Dependency: libopensync.so.1 for package: libopensync-plugin-syncml
--> Running transaction check
---> Package libopensync.i386 0:0.36-6.fc11 set to be updated
---> Package libopensync-plugin-syncml.i386 0:0.35-4.fc10 set to be updated
--> Processing Dependency: libsyncml.so.0 for package: libopensync-plugin-syncml
--> Finished Dependency Resolution
libopensync-plugin-syncml-0.35-4.fc10.i386 from rawhide has depsolving problems
  --> Missing Dependency: libsyncml.so.0 is needed by package libopensync-plugin-syncml-0.35-4.fc10.i386 (rawhide)
Error: Missing Dependency: libsyncml.so.0 is needed by package libopensync-plugin-syncml-0.35-4.fc10.i386 (rawhide)
Comment 1 Ruben Vermeersch 2009-03-08 11:13:41 EDT
This breaks synchronization with most modern Symbian (Nokia) based smartphones. Probably something that should be fixed before releasing F11.
Comment 2 Felix Kaechele 2009-03-31 10:15:10 EDT
This is due to an update made in libsyncml. It was updated to a newer version that is incompatible with any available libopensync-plugin-syncml version out there.
libsyncml will be reverted to the old version soon.

Reassigning this to me, as I b0rked it.
Comment 3 Ruben Vermeersch 2009-04-04 13:33:03 EDT
Fixed, yet breaks libopensync-plugin-vformat:

libopensync-plugin-vformat-0.36-2.fc11.i586 from rawhide has depsolving problems
  --> Missing Dependency: libopensync.so.1 is needed by package libopensync-plugin-vformat-0.36-2.fc11.i586 (rawhide)
Error: Missing Dependency: libopensync.so.1 is needed by package libopensync-plugin-vformat-0.36-2.fc11.i586 (rawhide)
Comment 4 Felix Kaechele 2009-04-11 17:57:52 EDT
closing this as libopensync-plugin-syncml is installable again

Note You need to log in before you can comment on or make changes to this bug.