Bug 488957 - /usr/share/system-config-cluster/misc/cluster.ng missing entries for validation.
/usr/share/system-config-cluster/misc/cluster.ng missing entries for validation.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-cluster (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 09:24 EST by Chris
Modified: 2016-04-26 09:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:54:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch file for the cluster.ng file only. (709 bytes, patch)
2009-03-06 09:24 EST, Chris
no flags Details | Diff
Proper Patch (821 bytes, patch)
2009-03-06 11:31 EST, Chris
no flags Details | Diff
expected_votes and quorum_dev_poll are independent now (745 bytes, text/plain)
2009-06-30 05:27 EDT, sfobug
no flags Details

  None (edit)
Description Chris 2009-03-06 09:24:22 EST
Created attachment 334298 [details]
patch file for the cluster.ng file only.

Description of problem:
The current cluster.ng file does not support quorum_dev_poll command which is required from this documen:
<cman quorum_dev_poll="50000">
...

The command:
xmllint --relaxng /usr/share/system-config-cluster/misc/cluster.ng /etc/cluster/cluster.conf 

produces:
/etc/cluster/cluster.conf:5: element cman: Relax-NG validity error : Invalid attribute quorum_dev_poll for element cman
/etc/cluster/cluster.conf:5: element cman: Relax-NG validity error : Expecting element clusternodes, got cman
/etc/cluster/cluster.conf:2: element cluster: Relax-NG validity error : Invalid sequence in interleave
/etc/cluster/cluster.conf:2: element cluster: Relax-NG validity error : Element cluster failed to validate content


Version-Release number of selected component (if applicable):


How reproducible:
Easily

Steps to Reproduce:
1. Execute: xmllint --relaxng /usr/share/system-config-cluster/misc/cluster.ng /etc/cluster/cluster.conf 
2. Ensure that your cluster.conf is already valid to begin with;  This bug isn't applicable to cluster.conf that are failing for other reasons.
Edit cluster.conf file and modify the <cman /> tag to include quorum_dev_poll
3. Execute: xmllint --relaxng /usr/share/system-config-cluster/misc/cluster.ng /etc/cluster/cluster.conf 
  
Actual results:

Validation Fails

Expected results:

Validation Passes

Additional info:
Our company does not use system-config-cluster at all;  However; we like to use the cluster.ng file that comes packed with it to validate any changes we make.  After following the document :  http://kbase.redhat.com/faq/docs/DOC-2882
our cluster configuration file no longer validates.  This is problematic for us since we've designed all our cluster configuration tools around ensuring that it is valid at all times.

Patch file is attached.
Comment 1 Chris 2009-03-06 11:31:28 EST
Created attachment 334315 [details]
Proper Patch

Disregard the last patch attached as here is the proper one.  I included in the system-config-cluster spec file (v1.0.55-1.0 at the time) and validation works fine now.
Comment 2 sfobug 2009-06-30 05:27:47 EDT
Created attachment 349927 [details]
expected_votes and quorum_dev_poll are independent now
Comment 8 Chris Ward 2010-02-11 05:26:37 EST
~~ Attention Customers and Partners - RHEL 5.5 Beta is now available on RHN ~~

RHEL 5.5 Beta has been released! There should be a fix present in this 
release that addresses your request. Please test and report back results 
here, by March 3rd 2010 (2010-03-03) or sooner.

Upon successful verification of this request, post your results and update 
the Verified field in Bugzilla with the appropriate value.

If you encounter any issues while testing, please describe them and set 
this bug into NEED_INFO. If you encounter new defects or have additional 
patch(es) to request for inclusion, please clone this bug per each request
and escalate through your support representative.
Comment 9 Brian Brock 2010-03-09 16:07:01 EST
fix verified in system-config-cluster-1.0.57-3
Comment 13 errata-xmlrpc 2010-03-30 04:54:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0288.html

Note You need to log in before you can comment on or make changes to this bug.