This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 488990 - Few duplicate API in org and org.trust
Few duplicate API in org and org.trust
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Sayli Karmarkar
:
Depends On:
Blocks: 456996
  Show dependency treegraph
 
Reported: 2009-03-06 11:45 EST by Sayli Karmarkar
Modified: 2015-03-22 21:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:54:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sayli Karmarkar 2009-03-06 11:45:35 EST
Description of problem:
Few duplicate API in org and org.trust:
1. addTrust
2. listTrusts
3. removeTrust


Expected results:
They should be present only in org.trust
Comment 1 Brad Buckingham 2009-03-06 12:17:33 EST
Agreed. Good catch. These APIs were initially created in org, but moved to org.trust.  Unfortunately, looks like they were not removed from the org handler... :(
Comment 2 Brad Buckingham 2009-03-06 14:43:41 EST
git commit: 285ceb3625b10c657689c7e1526b4eeafde9ec6c

Removed the APIs from the org handler.
Comment 3 Brad Buckingham 2009-03-17 17:17:47 EDT
mass move to ON_QA
Comment 4 Sayli Karmarkar 2009-03-18 16:04:23 EDT
verified.
Comment 5 Miroslav Suchý 2009-08-25 11:00:37 EDT
verified in stage on xen5
those apis are not presented in org, and are presented in org.trust
Comment 6 Brandon Perkins 2009-09-10 15:54:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.