Bug 489000 - Message body test in carod fails when body is not set
Message body test in carod fails when body is not set
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid (Show other bugs)
1.1
All Linux
urgent Severity urgent
: 1.1.1
: ---
Assigned To: Robert Rati
Martin Kudlej
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 12:16 EST by Matthew Farrellee
Modified: 2009-04-21 12:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 12:17:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Farrellee 2009-03-06 12:16:15 EST
condor-low-latency-1.0-10.el5
condor-job-hooks-common-1.0-5.el5

When sending a message from C++ that does not have a body set, e.g.

   Message message;
   message.getDeliveryProperties().setRoutingKey(work_queue_key);
   message.getMessageProperties().setMessageId(Uuid(true));
   message.getMessageProperties().setReplyTo(ReplyTo("amq.direct", response_queue_key));
   message.getHeaders().setInt("JobUniverse", 5);
   session.messageTransfer(arg::content=message, arg::destination="amq.direct");

carod incorrectly thinks there is a message body.

From carod:
      if saved_work.AMQP_msg.body != '':

needs to be:
      if saved_work.AMQP_msg.body != '' and saved_work.AMQP_msg.body != None:
Comment 1 Robert Rati 2009-03-06 15:03:31 EST
The AMQP message body is checked against None now.

Fixed in:
condor-low-latency-1.0-11
Comment 3 Martin Kudlej 2009-03-27 09:55:19 EDT
I cannot reproduce this. Submitting from c++ client doesn't work with emtpy body or with non-empty body. Client is from blog http://spinningmatt.wordpress.com/bucket/llcpp/ and settings are acording http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_MRG/1.1/html/Grid_User_Guide/chap-Grid_User_Guide-Low_latency_scheduling.html

I found in /var/lib/condor/log/StartLog
Warning, hook /usr/libexec/condor/hooks/hook_fetch_work.py (pid 7385) printed to stderr: Traceback (most recent call last):
  File "/usr/libexec/condor/hooks/hook_fetch_work.py", line 73, in ?
    sys.exit(main())
  File "/usr/libexec/condor/hooks/hook_fetch_work.py", line 62, in main
    decoded = pickle.loads(reply)
  File "/usr/lib/python2.4/pickle.py", line 1394, in loads
    return Unpickler(file).load()
  File "/usr/lib/python2.4/pickle.py", line 872, in load
    dispatch[key](self)
  File "/usr/lib/python2.4/pickle.py", line 894, in load_eof
    raise EOFError
EOFError

Is this warning a symptom of this bug or is it another bug?

-->NEEDINFO
Comment 4 Robert Rati 2009-03-27 14:04:13 EDT
No, that message is not related to this BZ.  That message is an indication that carod was stopped when work was being fetched and the hook got garbage.
Comment 5 Martin Kudlej 2009-04-01 09:13:31 EDT
Tested on rhel 5.3/4.7 and i386/x86_64 on condor-low-latency-1.0-12 and condor-job-hooks-common-1.0-5...OK

-->Verified
Comment 7 errata-xmlrpc 2009-04-21 12:17:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0434.html

Note You need to log in before you can comment on or make changes to this bug.