Bug 489012 - ftp installs not working
ftp installs not working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
high Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 13:08 EST by Patrick C. F. Ernzer
Modified: 2009-03-17 14:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 14:28:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tty3 (113.62 KB, image/png)
2009-03-06 16:07 EST, James Laska
no flags Details
tty4 (86.91 KB, image/png)
2009-03-06 16:08 EST, James Laska
no flags Details

  None (edit)
Description Patrick C. F. Ernzer 2009-03-06 13:08:11 EST
Description of problem:
I can not install with method=ftp:// nor repo=ftp://
http works just fine
jlaska confirme he sees the same

Version-Release number of selected component (if applicable):
anaconda-11.5.0.25-1

How reproducible:
always

Steps to Reproduce:
1. PXE boot anaconda rawhide (http://fpaste.org/paste/5228 has PXE menu entry)
  
Actual results:
anaconda asks for a URL, with the ftp path to install.img pre-filled. Nothing hits the xferlog of my FTP server. Selectig OK brings me immediately back to the same screen. Still no entries in xferlog. So it seems to not even try.

Expected results:
working ftp install

Additional info:
http as source works just fine.
this was discussed on #fedora-qa today
Comment 1 Chris Lumens 2009-03-06 13:10:59 EST
What's on tty3?
Comment 2 James Laska 2009-03-06 16:07:24 EST
Created attachment 334348 [details]
tty3
Comment 3 James Laska 2009-03-06 16:08:15 EST
Created attachment 334349 [details]
tty4
Comment 4 James Laska 2009-03-06 16:08:43 EST
Attached screenshots for tty3 and tty4
Comment 5 Patrick C. F. Ernzer 2009-03-06 18:24:16 EST
(In reply to comment #1)
> What's on tty3?  

get_connection (PID): NetworkManager connected
starting STEP_STAGE2
URL_STAGE_MAIN: url is
ftp://MYSERVER/mnt/rawhide/nightly/rawhide-20090306/x86_64/os/images/install.img
transferring ftp://MYSERVER/MYPATH/os/images/updates.img to a fd
transferring ftp://MYSERVER/MYPATH/os/images/product.img to a fd
transferring ftp://MYSERVER/MYPATH/os/images/install.img to a fd


the last 3 will repeat each time I hit OK on the anaconda pre-filled URL in the URL Setup screen, so sames as James. If at the URL Setup screen one just changes the ftp URL to the http URL anaconda continues fine.
Comment 7 James Laska 2009-03-17 12:08:27 EDT
Retested with rawhide today on i386 and ppc ... seems to work fine.

Patrick, can you retest to confirm?
Comment 8 Patrick C. F. Ernzer 2009-03-17 14:28:25 EDT
anaconda 11.5.0.31 on i386 works fine for me.
Thanks Chris for the fix and thanks James for the testing.

Note You need to log in before you can comment on or make changes to this bug.