Bug 489031 - login command does not allow for switching users
login command does not allow for switching users
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: util-linux (Show other bugs)
4.7
All Linux
low Severity low
: rc
: ---
Assigned To: Karel Zak
qe-baseos-daemons
:
Depends On:
Blocks: 495192
  Show dependency treegraph
 
Reported: 2009-03-06 15:30 EST by John Ruemker
Modified: 2011-02-16 09:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Prior to this update, the login(1) manual page contained information that the utility can be used to switch to another user. However, this is not true, and the utility is not designed for such purposes. With this update, the manual page has been corrected, and no longer contains misleading information.
Story Points: ---
Clone Of:
: 495192 (view as bug list)
Environment:
Last Closed: 2011-02-16 09:11:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ruemker 2009-03-06 15:30:37 EST
Description of problem: The manpage for the login command states:

"login is used when signing onto a system.  It can also be used to switch from one user to another at any time (most modern shells have support for this feature built into them, however)."

However it appears that switching-users with login does not work properly.  The issue seems to vary from not accepting keyboard input when run in an ssh session, to immediately returning to the prompt when run as a regular user, to failing with 'Login Incorrect' when trying to log in as root.  It only seems to work sometimes when logged in locally, running as root, and logging in as a regular user.   

Since the shells have built in support for switching users with su can we maybe remove the note in the manpage about being able to switch users?  Some customers of ours have been disappointed when the functionality did not match what was documented.

Version-Release number of selected component (if applicable): util-linux-2.12a-20.el4
Comment 1 Karel Zak 2009-03-09 04:48:57 EDT
You're right. The comment in the man page is nonsense. login(1) is not usable for users switching at all (see BUGS section in the same man page).

Thanks. Fixed in upstream code.
Comment 3 Jaromir Hradilek 2010-10-20 19:34:32 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, the login(1) manual page contained information that the utility can be used to switch to another user. However, this is not true, and the utility is not designed for such purposes. With this update, the manual page has been corrected, and no longer contains misleading information.
Comment 5 errata-xmlrpc 2011-02-16 09:11:55 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0233.html

Note You need to log in before you can comment on or make changes to this bug.