Bug 489052 - RFE: yum update/upgrade should automatically update yum and rpm first.
RFE: yum update/upgrade should automatically update yum and rpm first.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 18:03 EST by lexual
Modified: 2014-01-21 18:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 13:27:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lexual 2009-03-06 18:03:00 EST
Description of problem:

It seems common for update/upgrade problems to be resolved by telling a user to update rpm and yum packages before the rest of the system.

Is there any reason this couldn't happen by default anyway.

e.g.
$ yum upgrade
* yum upgrades yum and rpm
* yum upgrades everthing else.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 seth vidal 2009-03-09 15:03:32 EDT
for any given release it is generally not a problem.

For going from release to release it is a bit counter productive.

yum update rpm\* yum\* from f10->f11 or rawhide:

yum pulls in python
python pulls in glibc
glibc pulls in the world.
Comment 2 Rahul Sundaram 2009-03-16 19:47:13 EDT
Going from release to release, I don't think is counter productive. I used yum to upgrade to new releases almost exclusively.  For Fedora 11 alpha to later rawhide updates, it solves the md5sum mismatch errors a bit more gracefully.
Comment 3 James Antill 2009-05-05 13:27:01 EDT
> Going from release to release, I don't think is counter productive.

 Doing _this feature_ is counter productive, due to the fact that when glibc and python change those are brought in via. a yum update.
 Also even when they aren't brought in, pretty much all the testing in rawhide is with the latest python+glibc+sqlite+libxml+etc. ... having a lot of people only updating just yum, only on GA day, is probably not a great idea.

> For Fedora 11 alpha to later rawhide updates, it solves the md5sum 
> mismatch errors a bit more gracefully. 

 Indeed and that seems like a great thing to put in the Wiki. Also given that the fontconfig bug is still live that eats any sane persons manual yum update of F10 => F11, anyone not reading the wiki notes is totally screwed anyway.

Note You need to log in before you can comment on or make changes to this bug.