Bug 48906 - Samba Client just gets 0xc002002e instead of a text message
Samba Client just gets 0xc002002e instead of a text message
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-12 10:17 EDT by frank.lammers
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-26 21:12:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description frank.lammers 2001-07-12 10:17:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [de]C-CCK-MCD DT  (WinNT; U)

Description of problem:
A user browsing a samba share from within windows-explorer tries
to get ownership of a file on the samba share.
The user just gets a popup with 0xc002002e and no further explainations.
Also we know the function the user tries is not implemented it would
be better if the user gets a text message and not just a number.
like.:
---------------
0xC002002E RPC_NT_PROCNUM_OUT_OF_RANGE

The procedure number is out of range.
--------------
This is from the MS-Help.


How reproducible:
Always

Steps to Reproduce:
1. in the MS-Explorer right click on as file on the samba share 
2. try to get ownership of the file
3.
	

Expected Results:  A text message should come up 
maybe (Not Supported) 

Additional info:
Comment 1 Trond Eivind Glomsrxd 2001-07-13 18:37:21 EDT
Normally, I would think it the client programs responsibility to show error
messages... why do you think the samba server is capable of doing it for the
client? (not rhetorical, I'm interested). I'd also suggest than discussing this
on one of the sama-lists, to see what the developers think of it.
Comment 2 Andrew Bartlett 2001-08-26 21:12:22 EDT
It is up to the client to make somthing useful out of the error number and there
is nothing the Samba server can do in this case.  This does not rule out changes
in Samba however, as its often possible to return a different error code which
will actually be mapped to an error string by the client.

In this case I suspect the functionality simply was not implemented in the
version of Samba you are using (you failed to mention which one in the report,
and I don't know what RH71 shipped with).  More recent versions of samba have
the 'Take ownership' RPC implemented, but only for root (due to the way unix
perms operate).

Andrew Bartlett
abartlet@samba.org
Comment 3 Trond Eivind Glomsrxd 2001-08-26 21:17:29 EDT
Red Hat Linux 7.1 shipped with 2.0.7, this was upgraded to 2.0.10 in a security
errata.
Comment 4 Andrew Bartlett 2001-08-26 21:19:16 EDT
It is up to the client to make somthing useful out of the error number and there
is nothing the Samba server can do in this case.  This does not rule out changes
in Samba however, as its often possible to return a different error code which
will actually be mapped to an error string by the client.

In this case I suspect the functionality simply was not implemented in the
version of Samba you are using (you failed to mention which one in the report,
and I don't know what RH71 shipped with).  More recent versions of samba have
the 'Take ownership' RPC implemented, but only for root (due to the way unix
perms operate).

Andrew Bartlett
abartlet@samba.org

Note You need to log in before you can comment on or make changes to this bug.