Bug 489109 - Python scripts don't work with fontforge
Python scripts don't work with fontforge
Product: Fedora
Classification: Fedora
Component: fontforge (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-03-07 13:01 EST by Felix Schwarz
Modified: 2009-04-05 08:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-04-05 08:51:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Felix Schwarz 2009-03-07 13:01:45 EST
Description of problem:
Python bindings for fontforge don't work, importing the fontforge module fails on a 32 bit F11 rawhide system.

Version-Release number of selected component (if applicable):

Steps to Reproduce:
python -c 'import fontforge'
Actual results:
Traceback (most recent call last):
  File "<string>", line 1, in <module>
SystemError: Missing library: libgunicode

Expected results:
No output (=> fontforge library could be imported and is ready to use in Python)

Additional info:
/usr/lib/libgunicode.so.3[.0.1] is present but there is no symlink from /usr/lib/libgunicode.so. The same holds true for libgutils.so and libfontforge.so.
Comment 1 Kevin Fenzi 2009-03-08 21:02:52 EDT
Looks like debian is shipping a patch for this issue. Upstream is trying to dlopen the .so file it wants manually. 

Unfortunately the debian solution needs more work to work for us, as they hardcode lib in there and we need lib or lib64. ;( 

I will try and come up with a patch soon. ;(
Comment 2 Felix Schwarz 2009-03-09 13:04:38 EDT
I thought that maybe just supplying a symling from /usr/lib/libgunicode.so to /usr/lib/libgunicode.so.3 would be sufficient - at least this did the trick for me.
Comment 3 Kevin Fenzi 2009-04-02 02:32:30 EDT
Well, the link would be enough to get 32bit installs working, but would break on any 64bit one. (It hard codes /usr/lib/ instead of /usr/lib64). 

Anyhow, sorry for the delay here. 
I have checked in a patch that I think fixes this bug. 

It should be available in tomorrow's rawhide. Can you test and confirm it's fixed?
You can also find the build at: http://koji.fedoraproject.org/koji/taskinfo?taskID=1272152
Comment 4 Felix Schwarz 2009-04-05 08:51:06 EDT
Verified fixed with fontforge-20090224-2.fc11.i586 (on 32 bit platform).

Note You need to log in before you can comment on or make changes to this bug.