Bug 489140 - OpenJDK plugin doesn't work well with live.redhat.com
OpenJDK plugin doesn't work well with live.redhat.com
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-07 22:07 EST by Tom Lane
Modified: 2013-07-02 23:21 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-27 12:02:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Lane 2009-03-07 22:07:56 EST
Description of problem:
Red Hat's remote training infrastructure depends on some java applets that don't play very nicely with openjdk + firefox in Fedora 10 on an x86_64 platform.  It does work with the 32-bit version of firefox on the same platform, if I install Sun's JRE instead ... but I'd rather be using the default installation.

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-9.b14.fc10.x86_64
java-1.6.0-openjdk-plugin-1.6.0.0-9.b14.fc10.x86_64
firefox-3.0.6-1.fc10.x86_64

How reproducible:
It's not completely deterministic, but almost always fails if you have all three applets running,
and I've seen it happen with fewer. 

Steps to Reproduce:
1. Log in at https://live.redhat.com/vt/live/ , using an RHN login that is authorized to access training.
2. Open up both the "chatroom" and the virtual workstation, then click on the "classroom" link.
3. Bad things happen.
  
Actual results:
browser is partially frozen --- doesn't repaint its windows when they're moved, or respond to mouse or keyboard.  About all you can do is close all the windows via the window close controls, whereupon firefox does quit properly.

Expected results:
... should just work ...

Additional info:
Poking at it just now, it seems not to fail (or at least not so easily) when running firefox over an
ssh link to an X server on a Mac.  All the failures I had on Friday were using the local X server on
the F10 machine.  I can't tell if this is due to differences in the X server, or the much worse response time involved in this setup.

I realize this is a pretty inadequate bug report, but I don't know enough about openjdk to know what other info might be helpful.  I can reproduce this pretty much at will when using the local X server, and will be happy to supply more details if you tell me what to look at.
Comment 2 Deepak Bhole 2009-04-07 16:46:30 EDT
Can you reproduce this issue with the latest rawhide? I am unable to. I tried 3 simultaneous sessions, both cases - when logged into X and over ssh. In both cases, everything worked fine, no freezes.
Comment 3 Tom Lane 2009-04-07 17:07:01 EDT
I don't have a machine running rawhide ... did you mean latest F-10 by any chance?
Comment 4 Deepak Bhole 2009-04-07 17:30:28 EDT
Ah, sorry, your bug is against F10. For some reason I thought it was rawhide. I tested 64-bit rawhide only. I don't have an F10 64-bit machine around right now, but I'll set one up and test it there. I'll update this bug when I am done. Sorry about that.
Comment 5 Tom Lane 2009-04-07 18:55:48 EDT
Hmm, well, if it's okay in rawhide it may not be worth spending too much time on.
Comment 6 Bug Zapper 2009-11-18 04:11:48 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Deepak Bhole 2009-11-27 12:02:54 EST
I haven't been able to reproduce this issue. If you still see it, please feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.