Bug 489154 - No sound with 2.6.29-0.207.rc7.fc11.x86_64 (hda_intel - Too big adjustment)
No sound with 2.6.29-0.207.rc7.fc11.x86_64 (hda_intel - Too big adjustment)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-volume-manager (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-08 05:38 EDT by Thomas Meyer
Modified: 2009-04-09 19:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 10:14:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/proc/asound/cards (202 bytes, text/plain)
2009-03-08 05:38 EDT, Thomas Meyer
no flags Details
volume-control output device selection (33.49 KB, image/png)
2009-03-08 05:40 EDT, Thomas Meyer
no flags Details

  None (edit)
Description Thomas Meyer 2009-03-08 05:38:59 EDT
Created attachment 334432 [details]
/proc/asound/cards

Description of problem:
Under gnome-volume-manager/pulseaudio I cannot choose my hda_intel card as sound output device.
Also I get this messages in the dmesg:
ALSA sound/pci/hda/hda_intel.c:1100: Too big adjustment 32
ALSA sound/pci/hda/hda_intel.c:1100: Too big adjustment 32
ALSA sound/pci/hda/hda_intel.c:1100: Too big adjustment 32

Version-Release number of selected component (if applicable):
kernel is 2.6.29-0.207.rc7.fc11
gnome-media is 2.25.92-1.fc11
pulseaudio is 0.9.15-3.test5.fc11

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Thomas Meyer 2009-03-08 05:40:30 EDT
Created attachment 334433 [details]
volume-control output device selection
Comment 2 Thomas Meyer 2009-03-08 10:31:10 EDT
ok. this bug isn't a bug at all. I just need to select the correct output device "Internal Audio" to get sound; stupid me.

Sorry for the noise.
Comment 3 Matthieu Araman 2009-04-04 12:53:28 EDT
Hmm, I've got the same error message.
Same hardware, no sound, latest rawhide from today (20090404).
I don't understand why it's not a bug.
Workaround doesn't seem to work from me.

I'm going to do some more checks on my side.
Comment 4 Matthieu Araman 2009-04-05 10:33:13 EDT
Ok, got it working.(with internal audio)
fedora sound admin tools lack a test button...Filled bug 494196 for this.
I still think this error message shows a bug (or the setting shouldn't be offered to user)
Comment 5 Peeter Puusemp 2009-04-08 05:23:34 EDT
I have also hda_intel soundcard and no sound:
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe024000 irq 21

The platform is x86_64 Linux, Fedora 11 Beta. I have installed all available updates.

I have only the option Internal Audio in the Sound Preferences and it is already selected.

Additional information from the 'messages' log:

...
Apr  8 11:38:23 localhost pulseaudio[3087]: main.c: Called SUID root and real-time and/or high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
Apr  8 11:38:23 localhost pulseaudio[3087]: main.c: We are not in group 'pulse-rt', PolicyKit refuse to grant us the requested privileges and we have no increase RLIMIT_NICE/RLIMIT_RTPRIO resource limits.
Apr  8 11:38:23 localhost pulseaudio[3087]: main.c: For enabling real-time/high-priority scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
Apr  8 11:38:23 localhost pulseaudio[3091]: pid.c: Stale PID file, overwriting.
Apr  8 11:38:24 localhost kernel: fuse init (API version 7.11)
Apr  8 11:38:24 localhost pulseaudio[3115]: main.c: Called SUID root and real-time and/or high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
Apr  8 11:38:24 localhost pulseaudio[3115]: main.c: We are not in group 'pulse-rt', PolicyKit refuse to grant us the requested privileges and we have no increase RLIMIT_NICE/RLIMIT_RTPRIO resource limits.
Apr  8 11:38:24 localhost pulseaudio[3115]: main.c: For enabling real-time/high-priority scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
Apr  8 11:38:24 localhost kernel: ALSA sound/pci/hda/hda_intel.c:1100: Too big adjustment 32
Apr  8 11:38:24 localhost kernel: ALSA sound/pci/hda/hda_intel.c:1100: Too big adjustment 32
Apr  8 11:38:24 localhost kernel: ALSA sound/pci/hda/hda_intel.c:1100: Too big adjustment 32
Apr  8 11:38:24 localhost kernel: ALSA sound/pci/hda/hda_intel.c:1100: Too big adjustment 32
...
Comment 6 Peeter Puusemp 2009-04-09 19:12:30 EDT
I got the sound working with the command 'alsaunmute'.

The output of that command, just for information:

Unknown hardware: "HDA-Intel" "Analog Devices AD1988B" "HDA:11d4198b,104381f6,00100200" "" ""
Hardware is initialized using a guess method

Note You need to log in before you can comment on or make changes to this bug.