Bug 489214 - bugzilla shows wrong timezone across DST transitions
bugzilla shows wrong timezone across DST transitions
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
3.4
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-08 13:22 EDT by Tom Lane
Modified: 2013-07-02 23:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-22 15:48:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Lane 2009-03-08 13:22:58 EDT
Description of problem:
It appears that bugzilla incorrectly labels comments with the server's *current* timezone abbreviation,
not the time that the comments were actually generated.  This would be tolerable if the abbrev matched the displayed time of day, but it doesn't.

Version-Release number of selected component (if applicable):
whatever's in production as of 3/8/09

How reproducible:
100%

Steps to Reproduce:
1. look at bug #488941, for example
2. all comments are shown as EDT, including those from before this morning's DST changeover
3. Since the actual *times* of the older comments are in fact shown in EST, this is simply wrong.
  
Actual results:
factually incorrect time-of-day information

Expected results:
either the zone abbreviation should be made to match the displayed time, or vice versa.

Additional info:
I base my assertion that the older timestamps are wrong on looking at the time of receipt of the
associated nagmails.  The mails match the displayed time of day, which means that those times
of day are indeed EST not EDT.
Comment 1 Brennan Ashton 2009-03-15 02:48:33 EDT
Is there a reason the bz server(s) cannot be put on UTC and we can all just forget about this nonsense.  This seems like the right thing to do in the long run anyway.
Comment 2 Drew Northup 2009-11-12 11:57:01 EST
(In reply to comment #1)
> Is there a reason the bz server(s) cannot be put on UTC and we can all just
> forget about this nonsense.  This seems like the right thing to do in the long
> run anyway.  

I suspect that it wouldn't matter if the server is/isn't itself on UTC time as the way that the time is displayed is typically independent of the "hardware" time of the hosting machine.
This looks like a presentation layer problem, it is still there several months later, and it is annoying.
Comment 3 David Lawrence 2009-12-07 11:01:39 EST
Please try our new beta version of Bugzilla. With the new version, the user can set their own timezone in the userprefs.cgi screen and then all dates/times will be adjusted to display in the timezone calculated from the server's timezone.

Dave
Comment 4 David Lawrence 2010-01-15 11:55:46 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this bug will need to be re-verified against the new release. With
the updated code this bug may no longer be relevant or may have been fixed in
the new code. Updating bug version to 3.4.
Comment 5 Tom Lane 2010-01-22 13:28:41 EST
I see that the current version shows 'EST' or 'EDT' for different comments in a way that seems to relate to the time of year, so this may well work correctly now.  It'll be difficult to be really sure until the next DST change in March, though.
Comment 6 David Lawrence 2010-01-22 15:03:05 EST
(In reply to comment #5)
> I see that the current version shows 'EST' or 'EDT' for different comments in a
> way that seems to relate to the time of year, so this may well work correctly
> now.  It'll be difficult to be really sure until the next DST change in March,
> though.    

Yes the newer bugzilla now allows users to configure their own timezones to display the date information. We can leave this bug open for now if you want to see what happens in March, or just close it as CURRENTRELEASE and we can reopen it in march if needed (or open new one).

Thanks for verifying

Dave
Comment 7 Tom Lane 2010-01-22 15:27:14 EST
I put an entry in my calendar to remind me to recheck in March.  If you'd like to get this out of your face for now, feel free to close it.  I'll reopen if I see a problem.
Comment 8 David Lawrence 2010-01-22 15:48:14 EST
Thanks
Comment 9 Tom Lane 2010-03-14 12:47:23 EDT
this comment added at 12:47 EDT local time ... if it shows up that way, all is well.
Comment 10 David Lawrence 2010-03-14 14:45:53 EDT
(In reply to comment #9)
> this comment added at 12:47 EDT local time ... if it shows up that way, all is
> well.    

Whew, looks like it worked to me :)

Note You need to log in before you can comment on or make changes to this bug.