Bug 489251 - Update to mailman 2.1.12
Update to mailman 2.1.12
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mailman (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
http://www.list.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-09 01:44 EDT by Reed Loden
Modified: 2009-03-13 10:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 09:56:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reed Loden 2009-03-09 01:44:35 EDT
See announcement at:

http://mail.python.org/pipermail/mailman-announce/2009-February/000131.html
Comment 1 Daniel Novotny 2009-03-11 09:56:20 EDT
OK, upgraded 

mailman-2.1.12-1.fc11
Comment 2 Reed Loden 2009-03-12 20:11:41 EDT
+ echo 'Patch #1 (mailman-2.1.12-multimail.patch):'
Patch #1 (mailman-2.1.12-multimail.patch):
+ patch -p1 -b --suffix .multimail -s
1 out of 7 hunks FAILED -- saving rejects to file configure.in.rej

Did you upload the right patch? mailman-2.1.12-multimail.patch still mentions mailman-2.1.7.
Comment 3 Daniel Novotny 2009-03-13 07:07:20 EDT
hello, do you have the official .spec?

the patch fuzz factor has to be increased in order for the patch to pass

%define _default_patch_fuzz 3

the patching on my system (and koji) then goes like this:

+ echo 'Patch #1 (mailman-2.1.12-multimail.patch):'
Patch #1 (mailman-2.1.12-multimail.patch):
+ /usr/bin/patch -s -p1 -b --suffix .multimail --fuzz=3
+ /bin/cat /home/dnovotny/work/cvs/fedora/mailman/devel/mailman-2.1.12-multimail.patch

(notice the --fuzz=3)
Comment 4 Reed Loden 2009-03-13 10:41:50 EDT
(In reply to comment #3)
> hello, do you have the official .spec?

I do, but I add about 9 custom patches and change the release value to include the name of my organization. Besides that, there are no other changes between my spec file and the official one in CVS.

> the patch fuzz factor has to be increased in order for the patch to pass
> 
> %define _default_patch_fuzz 3

Yep, I have that.

> the patching on my system (and koji) then goes like this:
> 
> + echo 'Patch #1 (mailman-2.1.12-multimail.patch):'
> Patch #1 (mailman-2.1.12-multimail.patch):
> + /usr/bin/patch -s -p1 -b --suffix .multimail --fuzz=3
> + /bin/cat
> /home/dnovotny/work/cvs/fedora/mailman/devel/mailman-2.1.12-multimail.patch
> 
> (notice the --fuzz=3)  

I'm not getting that in my build... I'm just doing `rpmbuild -ba mailman.spec` to build the SRPM and RPM. Is there something else I should be doing to get _default_patch_fuzz to work?
Comment 5 Reed Loden 2009-03-13 10:45:20 EDT
Just for the record, comment #2 didn't cause me to full-stop or anything... I fixed the hunk that failed, remade the patch, and then built everything successfully. Just figured I'd report it here in case others ran into the same issue, but it just seems my build isn't including the proper fuzz setting. :(
Comment 6 Daniel Novotny 2009-03-13 10:55:29 EDT
Reed, can you post the modified patch here? Maybe I will rather include your patch, because someone else can get into the same trouble and the patch fuzz is an ugly solution anyway...

Note You need to log in before you can comment on or make changes to this bug.