Bug 489258 - Fn Keys Not Working (Asus N80 Series Laptop)
Fn Keys Not Working (Asus N80 Series Laptop)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-09 03:03 EDT by Jacob J. Morales
Modified: 2009-06-13 11:15 EDT (History)
4 users (show)

See Also:
Fixed In Version: Fedora 11 Final
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-13 11:15:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jacob J. Morales 2009-03-09 03:03:53 EDT
Description of problem:

The Following behavior happens when I try to use the Fn Keys on the laptop

Fn+F1=Sleep (Works)
Fn+F2=Wireless Off (Doesn't Work)
Fn+F7=LCD Off (Works)
fn+F8=LCD/Display (Not Sure)
Fn+F10=Mute (Doesn't Work)
Fn+F11=Vol. Up (Doesn't Work)
Fn+F12=Vol. Down (Doesn't Work)

How reproducible:

Install Fedora 10


Steps to Reproduce:

1. Press the Fn Keys mentioned above
  
Actual results:

None


Expected results:

Have functional FN keys

Additional Information:

I have tried to configure the keyboard using system>preferences>hardware>keyboard and selected ASUS laptop keyboard from the menu.

The function keys work under ubuntu 8.04 with no problem.
Comment 1 Steven M. Parrish 2009-03-16 20:41:44 EDT
acpi is not the correct component for this issue.  Reassigning
Comment 2 Zdenek Prikryl 2009-03-17 04:01:39 EDT
Hello,
if the sound control isn't implemented directly in hw, then fn keys usually  generate acpi events. This events can by caught by acpid or other watcher (gnome-power-manager etc.).

So, do Fn+F1[012] keys generate any acpi events? You can see them if you disable acpid and rerun it in a debug mode (don't forget to paste an output here).

$ service acpid stop
$ acpid -d
Try to push fn keys.

What desktop environment do you use?
Comment 3 Stefano Tortarolo 2009-04-08 18:28:25 EDT
I have got an Asus F3F and I have the same problem.
Just some notes... Fn keys generate acpi events and I'm able to catch them (try acpi_listen). Actually I solved configuring them manually in /etc/acpi/events and then using acpi-keys by Vincent Untz (http://www.gnome.org/~vuntz/code/acpi-keys-0.2.tar.gz). This basically emulates a "normal" system raising XF86 codes. I must admit that this way is very handy since this events can be configured in Kde4 (and I guess Gnome as well).

So to sum up, it's possible to configure them in a proper way, it just would be nice to have this done automatically (e.g. *buntu do this pretty well).

Let me know if you need more information.
Comment 4 Zdenek Prikryl 2009-04-16 02:33:22 EDT
Probably there is missing keymap for this laptop series in HAL's fdi files. So, reassigning the bug to hal.
Comment 5 Stefano Tortarolo 2009-05-18 13:53:22 EDT
I've just upgraded to rawhide, volume keys now works correctly!
However, there are some keys that are still not recognized (brightness, play/pause...).

I couldn't find how the bug has been fixed, I'd like to provide more information if necessary.
Comment 6 Stefano Tortarolo 2009-05-22 14:26:00 EDT
Uhm... multimedia keys are actually recognized (even though qt doesn't support my multimedia stop key and a couple of others...)

Keys that don't work are so:
- brightness ones:
 -- up:
   video LCDD 00000086
  -- down:
   video LCDD 00000087
  (It's weird, however, that they don't trigger any hotkey ATKD *)
- "speed key" (I really don't know its real name... :D)
  hotkey ATKD 0000005c
- touchpad on/off
  hotkey ATKD 0000006b
- screen key
  hotkey ATKD 0000008a

The most annoying actually are the brightness ones.
I can say that the others are not mapped to any XF86 code since they don't trigger any binding in kde nor any qt-related error.
Comment 7 Jacob J. Morales 2009-06-13 11:15:01 EDT
I just installed Fedora 11 Final.  This bug seems to be finally fixed!  Thanks for all the replies.

Note You need to log in before you can comment on or make changes to this bug.