Bug 489278 - /etc/init.d/unbound reload silently kills the process
/etc/init.d/unbound reload silently kills the process
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: unbound (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Avesh Agarwal
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-09 06:03 EDT by Noa Resare
Modified: 2012-04-16 17:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-16 17:33:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noa Resare 2009-03-09 06:03:46 EDT
Description of problem:

I updated /etc/unbound.conf and assumed that '/etc/init.d/unbound reload' 
should read my changes into the currently running server. However it turns out
that it exits silently and the server process exits with the following message 
in /var/log/messages:

Mar  9 09:58:25 viktor unbound: [27476:0] notice: quit on signal, no cleanup and statistics, because installed libevent version is not threadsafe


Version-Release number of selected component (if applicable):
unbound-1.0.2-5.el5

How reproducible:
always

Steps to Reproduce:
1. install unbound
2. start it with /etc/init.d/unbound start
3. verify that the process runs
4. Run /etc/init.d/unbound reload

Actual results:
the unbound process exits with a message in syslog

Expected results:
reloaded configuration files and continued unbound operation

Additional info:
Comment 2 Noa Resare 2009-05-20 07:57:12 EDT
This is due to upstream not providing a recent libevent, causing all signals to shut down unbound. 

IMHO the reasonable workaround is to make the reload() function in the init script an alias to restart().

This can probably be switched back when upstream releases it's next major version, with an updated libevent, but for EL4 and EL5 we're stuck with this.
Comment 3 Paul Wouters 2012-02-27 21:35:52 EST
I've put Noa's suggestion in unbound-1.4.16-2 for EL5  (unbound has no el4 branch)

Note You need to log in before you can comment on or make changes to this bug.