Bug 489336 - Full disclosure of Fedora/Redhat Enterprise compromise is not available.
Full disclosure of Fedora/Redhat Enterprise compromise is not available.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-09 11:33 EDT by coupongang
Modified: 2009-03-10 11:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 13:27:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description coupongang 2009-03-09 11:33:57 EDT
Description of problem:

Full disclosure of Fedora/Redhat Enterprise compromise is not available.

https://www.redhat.com/archives/fedora-announce-list/2008-August/msg00012.html

Is 6 months of silence enough to endure?

Version-Release number of selected component (if applicable):

Not disclosed.

How reproducible:

Read the WWW.

Steps to Reproduce:
1.  Not disclosed.
2.
3.
  
Actual results:

Red Hat remains silent.

Expected results:

Red Hat discloses the nature of the Breach and steps to prevent same in the future.

Additional info:
Comment 1 Jim Wildman 2009-03-09 11:59:38 EDT
Things we know as it pertains to RHEL....
1) No source code under RH control was changed (per various announcements)
2) Some one was able to get a trojaned ssh package signed (per recent  Red Hat mag article)
3) The package did not get distributed via RHN (per various announcements)


I assume whoever was smart enough to get the package in, got it out, ergo there is a correctly signed, trojaned ssh package in the wild somewhere.  I question whether Red Hat has a copy of the trojaned, signed package since their suggestions for detecting it are superficial. 

I initially hoped that Red Hat would at least be able to produce network traces and logs such as generated by the Gentoo project several years ago.  Or that they could release an outside audit/review of their procedures with a high level remediation plan, etc.  

I have concluded they are not capable of that level of analysis or openness.
Comment 2 R P Herrold 2009-03-09 12:15:54 EDT
link is Item 5 'post mortem' at http://www.owlriver.com/projects/packaging/#trust as to that Gentoo response
Comment 3 Josh Boyer 2009-03-09 13:27:38 EDT
This isn't a kernel bug.  Nor is the package bugzilla a way to report issues with this.

Note You need to log in before you can comment on or make changes to this bug.