Bug 489402 - Default xfce icon theme not displaying several icons
Default xfce icon theme not displaying several icons
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xfce4-icon-theme (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
: 491118 (view as bug list)
Depends On:
Blocks: 491089 491094 491109 491115
  Show dependency treegraph
 
Reported: 2009-03-09 16:48 EDT by Jarod Wilson
Modified: 2009-04-17 15:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 14:59:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 5163 None None None Never

  None (edit)
Description Jarod Wilson 2009-03-09 16:48:02 EDT
Description of problem:
Clean F11 install w/XFCE desktop chosen at install time, the desktop comes up, and the trash icon from the dock is missing, the "File system" icon on the desktop is missing, and all the folder icons that should be seen in Thunar are missing. Same issue for icon themes Fedora, GNOME, Mist, and so on, the only one that results in all icons being displayed is the xfce-provided rodent theme.

Version-Release number of selected component (if applicable):
xfce4-icon-theme-4.4.3-2.fc11


How reproducible:
Just do a default install and login.

Additional info:
Not sure if this was the appropriate component to file against, but hopefully close enough... :)
Comment 1 Jarod Wilson 2009-03-18 08:45:09 EDT
Nb: I believe I've seen a similar issue with a gnome install as well now, so this might be a fedora/gnome icon set issue in general -- possibly fixed by now, not sure, need to look into it again...
Comment 2 Kevin Fenzi 2009-03-18 12:35:23 EDT
I was finally able to get livecd's to compose and boot last night. 
I don't see the issue there or on my rawhide machines here. ;( 

So, it's something related to a missing package or old config. 

If you make a brand new user does it happen?
Comment 3 Christoph Wickert 2009-03-25 13:27:09 EDT
*** Bug 491118 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Wickert 2009-03-25 13:29:23 EDT
-1 for switching to Tango. As it's not possible to stick with Fedora/Gnome/Mist we should switch to Rodent, which is Xfce's default. Rodent lacks Fedora-specific icons, so need to patch it to inherit Fedora.

(I'd rather see Fedora filled up with Rodent icons, but this would mean patching fedora-icon-theme to inherit something that is not necessarily installed.)
Comment 5 Kevin Fenzi 2009-03-25 14:51:05 EDT
I kinda like tango, but I don't care too much. ;) 

How about Rodent inheriting from Mist? 
You want to spin up a patch for this and we can test that all icons are ok? 

Or would you like me to? (I probibly will get time later this week).
Comment 6 Christoph Wickert 2009-03-25 15:04:51 EDT
(In reply to comment #5)
> I kinda like tango, but I don't care too much. ;) 

Me ether, but IMO we should ship ether our default and upstream's. 

> How about Rodent inheriting from Mist? 

Fedora already inherits Mist and only adds some specific icons (redhat-*.png, openofficeorg-*.png) so that the main menu looks the same on all desktops.

> You want to spin up a patch for this and we can test that all icons are ok? 
> 
> Or would you like me to? (I probibly will get time later this week). 

Will do.
Comment 7 Kevin Fenzi 2009-03-25 16:04:01 EDT
Well, upstream default currently is nothing. ;) Rodent does not have full coverage anymore. 
Debian is using tango I think. If we can get coverage from Rodent+Fedora thats fine with me.
Comment 8 Christoph Wickert 2009-04-17 14:59:28 EDT
Ok then, fixed in xfce4-icon-theme-4.4.3-3.fc{11,12}. If anybody misses an icon, please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.