Bug 489522 - Duplicate channels listed in activation keys channel selection boxes after satellite-sync
Duplicate channels listed in activation keys channel selection boxes after sa...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Steve Salevan
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-03-10 11:28 EDT by Steve Salevan
Modified: 2009-09-10 16:34 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:34:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-03-10 11:28:50 EDT
Description of problem:
If a user syncs a channel to a Satellite via satellite-sync, then navigates to the Activation Key creation page:

/rhn/activationkeys/Create.do

and then looks inside the 'Base Channels' selector, the selector will contain
duplicate entries for all synced channels.

Version-Release number of selected component (if applicable):
530-re20090306.2

How reproducible:
Always

Steps to Reproduce:
1. Sync a channel via satellite-sync
2. Navigate to /rhn/activationkeys/Create.do
3. Look inside the 'Base Channels' selector

Actual results:
Duplicate entries exist for all synced channels

Expected results:
Only single instances of each synced channel appear in selector

Additional info:
Comment 1 Justin Sherrill 2009-03-12 16:31:51 EDT
Looks like this was fixed as well in 480674, moving to modified.
Comment 2 Steve Salevan 2009-03-31 14:09:52 EDT
Looks fixed in 530-re20090327.0, moving to VERIFIED.
Comment 3 Milan Zazrivec 2009-08-14 08:52:55 EDT
Verified in stage -> RELEASE_PENDING.
Comment 4 Brandon Perkins 2009-09-10 16:34:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.