Bug 489532 - multi-org, channel sharing, moving from public to protected and "deny access" does not remove channel
multi-org, channel sharing, moving from public to protected and "deny access"...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Corey Welton
http://grandprix.rhndev.redhat.com/rh...
:
Depends On:
Blocks: 456998 486216
  Show dependency treegraph
 
Reported: 2009-03-10 12:05 EDT by wes hayutin
Modified: 2009-09-10 14:15 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:15:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
recreate steps (3.51 KB, text/plain)
2009-04-13 11:49 EDT, wes hayutin
no flags Details
working screenshot (21.63 KB, image/png)
2009-04-13 23:25 EDT, Jesus M. Rodriguez
no flags Details

  None (edit)
Description wes hayutin 2009-03-10 12:05:43 EDT
Description of problem:
Satellite-5.3.0-RHEL5-re20090306.2-i386-embedded-oracle.iso

multi-org, channel sharing, moving from public to protected and "deny access" does not remove channel

recreate.
Run Multi-Org2 automation

test  "test08_04_MultiOrg2_CheckSharedChannelRemoved_InOverview"

fails
Comment 1 Shannon Hughes 2009-03-31 16:28:58 EDT
put the fix in to delete the channel when denying access during access change from public to protected. 

manual test plan: 

1) have two trusted orgs
2) have one share channel to another with other org subscribed
3) make shared channel public
4) change access to protected and deny access
5) go to org that was subscribed and check systems overview
6) confirm the system that was using the shared channel now has a none for its base channel
Comment 2 Shannon Hughes 2009-03-31 16:33:12 EDT
also, please qa 493167 at the same time this bug gets looked at. same test plan.
Comment 3 Corey Welton 2009-04-09 10:40:51 EDT
QA Verified.
Comment 4 wes hayutin 2009-04-13 11:21:22 EDT
fails in 4/9 x86 rhel 5
Comment 5 wes hayutin 2009-04-13 11:22:37 EDT
more specifically step 6 is not working from comment #1
Comment 6 wes hayutin 2009-04-13 11:49:53 EDT
Created attachment 339333 [details]
recreate steps

hopefully one can follow along as pseudo code, or set up auto :)
Comment 7 wes hayutin 2009-04-13 11:50:41 EDT
the very last line of code fails
Comment 8 Corey Welton 2009-04-13 12:37:07 EDT
I have reverified a couple times that steps from comment #1 work in build "Satellite-5.3.0-RHEL5-re20090403.2-i386-embedded-oracle.iso".  I have also manually re-created the test steps per automation:


1. Manually set channel to 'private' [IRhnBase.CHANNEL_SHARE_PRIVATE, IRhnBase.CHANNEL_SHARE_ALL_USERS, false]
2. Manually set channel to 'protected/allow all' [IRhnBase.CHANNEL_SHARE_PROTECTED, IRhnBase.CHANNEL_SHARE_ALL_USERS, true] 
3. Manually subscribed system and installed package (confirmed in UI that package from channel was listed as being used on said system)
4. Manually set channel to 'public' [IRhnBase.CHANNEL_SHARE_PUBLIC, IRhnBase.CHANNEL_SHARE_ALL_USERS, true)]
5. Manually set channel to 'protected/deny' [IRhnBase.CHANNEL_SHARE_PROTECTED, IRhnBase.CHANNEL_SHARE_ALL_USERS, false]
6. Viewed system in webui.

Results:
Updates   	Errata   	Packages   	System   	Base Channel   	Entitlement
System is up to date 	0 	0 	Non-Virtual System jiaozi.usersys.redhat.com 	(none) 	Management 

This means that either there's a regression between this and a more recent build, or the automation is catching something that these steps don't cover.

This can be retested in the latest build, but needs further investigation.
Comment 9 Jesus M. Rodriguez 2009-04-13 23:25:41 EDT
Created attachment 339414 [details]
working screenshot

I couldn't recreate this problem, seems to work just fine. It is possible this didn't work in the 0409 iso because of the build problem we had with the java rpm.
Comment 10 Jesus M. Rodriguez 2009-04-13 23:26:18 EDT
Retest on the 4/13 iso
Comment 11 Corey Welton 2009-04-17 11:08:56 EDT
QA Verified:

System is up to date  	  dhcp231-25.rdu.redhat.com  	 (none)  	 4/17/09 10:52:50 AM EDT  	 User Icon  org2_admin  	Management
Comment 12 John Sefler 2009-09-03 15:31:46 EDT
Verified on staged (Satellite-5.3.0-RHEL5-re20090724.0) with updates from Aug 20, 2009

scenrio in Comment #1 passes
Comment 13 John Sefler 2009-09-03 15:32:09 EDT
moving to RELEASE_PENDING
Comment 14 Brandon Perkins 2009-09-10 14:15:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.