Bug 489561 - Support Splash Page Links - English
Support Splash Page Links - English
Status: CLOSED CURRENTRELEASE
Product: JBoss Customer Support Portal
Classification: Retired
Component: Web-General (Show other bugs)
MR10
All Linux
low Severity medium
: ---
: ---
Assigned To: John Sanda
:
: 490161 (view as bug list)
Depends On: 483554
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 13:32 EDT by Amanda Carter
Modified: 2009-04-24 16:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 16:22:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amanda Carter 2009-03-10 13:32:26 EDT
Description of problem:

The links on this page are now shown as Contact Sales and then 2 listings for Contact Customer Service. It should be as follows:

* Value of a JBoss Subscription <http://www.jboss.com/services/subscriptions/>
* Contact Sales <https://www.redhat.com/apps/webform.html?event_type=contact_sales&eid=164>
* Contact Customer Service <http://www.redhat.com/about/contact/dir/#custservice>


Version-Release number of selected component (if applicable):


How reproducible:

Log into the CSP as a user with no supported entitlements with English as language preference. Navigate to Support tab.


Actual results:

See Above

Expected results:

See Above

Additional info:
Comment 1 Jessica 2009-03-13 12:11:42 EDT
*** Bug 490161 has been marked as a duplicate of this bug. ***
Comment 2 Grant Shipley 2009-03-26 15:16:11 EDT
Approved. Moving to backlog.
Comment 3 John Sanda 2009-03-26 17:23:04 EDT
Committed r4693 which updates the link to be what is in the initial description. I may need to get updated translations for this as well.
Comment 4 John Sanda 2009-03-27 11:24:21 EDT
This is available for testing in QA. Amanda, can you verify that the content is correct? You can log in as jsanda_no_ent / redhat if you don't already have a user. Thanks.
Comment 5 Amanda Carter 2009-03-27 12:21:22 EDT
QA for English display - pass.

For JP and CN displays, the links shown were customized since they point to .cn and .jp pages which do not have the same content available. The paragraph on the page is standard across languages. The desired behavior is live in Production and is summarized here:

CN page - 1 link only: 
http://www.redhat.com.cn/about/

JP page - 2 links only:
http://www.jp.redhat.com/contact
http://www.jp.redhat.com/jboss/support

Localization Note: Re-implementing this mirrors prod, thus causes no change in localization. JP localization in prod is 100% correct and signed off on; CN localization in prod has a bug filed against it ( https://bugzilla.redhat.com/show_bug.cgi?id=489562 ) but is otherwise correct.
Comment 6 John Sanda 2009-03-30 16:36:33 EDT
Committed r4700 which adds logic to display the localized links for Japanese and Chinese. It defaults to displaying the English links for which the text is not retrieved from any localized message resource bundle.
Comment 7 John Sanda 2009-03-31 09:46:58 EDT
r4700 has been pushed to QA.
Comment 8 Amanda Carter 2009-03-31 10:27:17 EDT
I sign off on the changes pushed to QA. I just note that BZ 489562 has not been resolved yet and also affects these pages.

Amanda

Note You need to log in before you can comment on or make changes to this bug.