Bug 489575 - opengl screensaver hangs/crashes system with xorg-x11-drv-ati-6.10.0-2.fc10.i386
opengl screensaver hangs/crashes system with xorg-x11-drv-ati-6.10.0-2.fc10.i386
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i686 Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 14:19 EDT by Eddie Lania
Modified: 2018-04-11 07:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-14 04:52:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log.old from after a crash (101.83 KB, text/plain)
2009-03-11 12:40 EDT, Eddie Lania
no flags Details
dmesg with nomodeset kernel parameter in grub (26.57 KB, text/plain)
2009-03-12 12:27 EDT, Eddie Lania
no flags Details
xorg.0.log from after adding nomodeset kernel parameter. (170.96 KB, text/plain)
2009-03-12 12:28 EDT, Eddie Lania
no flags Details

  None (edit)
Description Eddie Lania 2009-03-10 14:19:33 EDT
Description of problem: opengl screensaver hangs/crashes system with xorg-x11-drv-ati-6.10.0-2.fc10.i386


Version-Release number of selected component (if applicable):

xorg-x11-drv-ati-6.10.0-2.fc10.i386

How reproducible:


Steps to Reproduce:
1. Install opengl screensaver with xorg-x11-drv-ati-6.10.0-2.fc10.i386
2. Open system - preferences - Look and Feel - Screensaver
3. If it already not hangs here, try to select an opengl screensaver.
  
Actual results: System stutters, then hangs/crashes.


Expected results: Normal screensaver behaviour


Additional info: Kernel = 2.6.27.19-170.2.35.fc10.i686

No additional settings in xorg.conf

rpm -qa | grep -i "screensaver"
xscreensaver-gl-extras-gss-5.08-5.fc10.i386
xscreensaver-gl-extras-5.08-5.fc10.i386
fedorainfinity-screensaver-theme-1.0.0-1.fc8.noarch
xscreensaver-base-5.08-5.fc10.i386
xscreensaver-gl-base-5.08-5.fc10.i386
rss-glx-xscreensaver-0.8.2.p-1.fc10.i386
xscreensaver-5.08-5.fc10.i386
xscreensaver-extras-5.08-5.fc10.i386
rss-glx-gnome-screensaver-0.8.2.p-1.fc10.i386
fedora-screensaver-theme-1.0.0-3.fc10.noarch
gnome-screensaver-2.24.1-2.fc10.i386
xscreensaver-extras-gss-5.08-5.fc10.i386
Comment 1 Eddie Lania 2009-03-10 15:19:14 EDT
To be precise, the crash happens when starting: gnome-screensaver-preferences.
After the crash when I restart, I cannot find anything strange in the /var/log/messages or /var/log/Xorg.0.log.old.

I would like to debug this so that I can report some debug log here, but I don't know how to do that.
Comment 3 Eddie Lania 2009-03-10 15:40:59 EDT
Using gconf-editor I edited the settings for gnome-screensaver.

I was using "blocktube" as the preferred screensaver and changed that.

Now, when I start "gnome-screensaver-prefences" the system does not lock-up anymore.

But I do however see the following message in the terminal from where I start gnome-screensaver-preferences:

 gnome-screensaver-preferences 
** (gnome-screensaver-preferences:3698): DEBUG: Found best visual for GL: 0x21
Comment 4 Matěj Cepl 2009-03-10 18:43:32 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Eddie Lania 2009-03-11 12:40:49 EDT
Created attachment 334834 [details]
Xorg.0.log.old from after a crash

I have removed xorg.conf and tested again per as requested.

The same error/crash still occurs.

The attachment is the xorg.0.log.old from afther the crash.
Comment 6 François Cami 2009-03-11 17:46:13 EDT
Eddie,

Could you also add "dmesg" output as uncompressed text/plain
attachment to the bug ?
If you are not yet using this, could you please try adding the
nomodeset kernel parameter and report if it fixes the problem ?

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Eddie Lania 2009-03-12 12:27:23 EDT
Created attachment 334960 [details]
dmesg with nomodeset kernel parameter in grub

Hereby my dmesg after adding parameter "nomodeset" to kernel.

It solves the problem.

It also enables the "rage theatre" chip.

I will also send the xorg.0.log.

Must I make a new initrd? I recently changed back from the fglrx driver which blacklists radeon. After this switch I have not created a new initrd image.

Do you understand what I mean?

regards.

Eddie.
Comment 8 Eddie Lania 2009-03-12 12:28:46 EDT
Created attachment 334961 [details]
xorg.0.log from after adding nomodeset kernel parameter.

xorg.0.log from after setting "nomodeset" kernel parameter.
Comment 9 François Cami 2009-03-12 17:13:08 EDT
Thanks for providing the needed data.
No signs of fglrx in your logs, good.
NB: KMS (modesetting) + AGP do not easily match...

Switching to assigned, severity set to low since there is a workaround.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Eddie Lania 2009-05-13 15:21:19 EDT
I am on F11 now. No problems here with the screen-saver.
Comment 11 Alexei Podtelezhnikov 2009-12-18 08:37:59 EST
Heh. F12 reliably locks up.

Note You need to log in before you can comment on or make changes to this bug.