Bug 489578 - Individual cpu core will fail cpuscaling depending upon what type of drive is used and whether INFO runs before or after test
Individual cpu core will fail cpuscaling depending upon what type of drive is...
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.3
All Linux
low Severity medium
: ---
: ---
Assigned To: Rob Landry
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 14:42 EDT by Gregg Shick
Modified: 2014-03-25 20:56 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-21 11:59:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
passing results where cpuscaling is run by itself. No info run. (20.08 KB, application/octet-stream)
2009-03-10 14:42 EDT, Gregg Shick
no flags Details
Failing result where info is run first. (1.99 MB, application/octet-stream)
2009-03-10 14:49 EDT, Gregg Shick
no flags Details
passing sata results where info was run first. (1.10 MB, application/octet-stream)
2009-03-10 14:49 EDT, Gregg Shick
no flags Details
patch to check loadave is < 1 and perform a sync before starting scaling test (954 bytes, patch)
2010-03-03 18:30 EST, Rob Landry
no flags Details | Diff

  None (edit)
Description Gregg Shick 2009-03-10 14:42:55 EDT
Created attachment 334692 [details]
passing results where cpuscaling is run by itself.  No info run.

Description of problem: Core 0 of the cpuscaling test will fail when the drive is a SSD and info is run before the test.  


Version-Release number of selected component (if applicable): RH 5.3 x86 or x64 / HTS 5.3-15


How reproducible: Every time


Steps to Reproduce:
1.Install RH 5.3 on a blade that contains an SSD. 
2.Load HTS 5.3-15 and create the testplan.  Add the cpuscaling test for each core manually. Disable all other tests except for info and cpuscaling. 
3.Start test with "hts certify". Info will run and cpuscaling will launch immediately after info completes.  Core 0 will fail, the other cores will pass.  
  
Actual results:  When info is run first and then cpuscaling, the 0 core will fail every time.  If I run cpuscaling without info, it passes every time.  If I execute "hts certify --test cpuscaling --device cpu0", info will run after the cpuscaling test and the test will pass.  


Expected results:Test passes no matter what drive is used or how the test is launched.


Additional info:We have run the same test substituting a sata driver for the SSD.  It will pass no matter what the run order is.
Comment 1 Gregg Shick 2009-03-10 14:49:23 EDT
Created attachment 334695 [details]
Failing result where info is run first.
Comment 2 Gregg Shick 2009-03-10 14:49:53 EDT
Created attachment 334696 [details]
passing sata results where info was run first.
Comment 3 David Aquilina 2009-03-18 11:09:57 EDT
Gregg, 

Looking at the sosreport it appears that this is a Nehalem-based system you're testing on. Does this system support TurboBoost and is it enabled in the BIOS? 

-David
Comment 4 Gwen Lapo 2009-05-21 14:56:53 EDT
Issue is seen with both turboboost on and off.
Comment 9 Gregg Shick 2009-08-25 11:15:36 EDT
We were unable to reproduce this issue with RH5 U4 and hts -17
Comment 27 Rob Landry 2010-03-03 18:30:28 EST
Created attachment 397684 [details]
patch to check loadave is < 1 and perform a sync before starting scaling test
Comment 28 Greg Nichols 2010-03-04 13:56:51 EST
Committed R12
Comment 34 errata-xmlrpc 2010-04-21 11:59:21 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0365.html

Note You need to log in before you can comment on or make changes to this bug.