Bug 489585 - Missing Dependency: libwebkit is needed by package devhelp
Missing Dependency: libwebkit is needed by package devhelp
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: devhelp (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 15:23 EDT by Thomas Meyer
Modified: 2009-03-11 05:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 05:57:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Meyer 2009-03-10 15:23:02 EDT
Description of problem:

$ sudo yum upgrade
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libwebkit-1.0.so.1()(64bit) for package: devhelp
--> Processing Dependency: libwebkit-1.0.so.1()(64bit) for package: gimp-help-browser
---> Package WebKit-gtk.x86_64 0:1.1.1-1.fc11 set to be updated
--> Finished Dependency Resolution
devhelp-0.23-5.fc11.x86_64 from installed has depsolving problems
  --> Missing Dependency: libwebkit-1.0.so.1()(64bit) is needed by package devhelp-0.23-5.fc11.x86_64 (installed)
2:gimp-help-browser-2.6.5-2.fc11.x86_64 from installed has depsolving problems
  --> Missing Dependency: libwebkit-1.0.so.1()(64bit) is needed by package 2:gimp-help-browser-2.6.5-2.fc11.x86_64 (installed)
Error: Missing Dependency: libwebkit-1.0.so.1()(64bit) is needed by package devhelp-0.23-5.fc11.x86_64 (installed)
Error: Missing Dependency: libwebkit-1.0.so.1()(64bit) is needed by package 2:gimp-help-browser-2.6.5-2.fc11.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes

Shall I open bugs for this kind of error (Missing Dependency) in rawhide?
What's the consensus about this?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Barnes 2009-03-11 05:57:57 EDT
Dependency already specified, just needs a rebuild for the new WebKit ABI.

Fixed in devhelp-0.23-6.fc11.

Note You need to log in before you can comment on or make changes to this bug.