Bug 489588 - opreport failed to generate the XML output
opreport failed to generate the XML output
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: oprofile (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: William Cohen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 15:43 EDT by Suravee Suthikulpanit
Modified: 2009-04-17 14:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.9.4-6.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 11:06:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is a good version of the XML output. (67.81 KB, application/xml)
2009-03-10 15:45 EDT, Suravee Suthikulpanit
no flags Details

  None (edit)
Description Suravee Suthikulpanit 2009-03-10 15:43:52 EDT
Description of problem:
Opreport failed to generate the XML output.
    - This does not happen when I use the locally build oproifile-0.9.4 (upstream).
    - This does not happen in the 64-bit Fedora10 distribution.

Version-Release number of selected component (if applicable):
oprofile-0.9.4-3.fc10.i386

How reproducible:
/usr/bin/opreport -wdlX --session-dir /var/lib/oprofile

Steps to Reproduce:
1. Run a profile using opcontrol.
2. Run /usr/bin/opreport -X.
  
Actual results:
-------------------- BEGIN ---------------------
[root@localhost oprofile-0.9.4]# /usr/bin/opreport -wdlX --session-dir /var/lib/oprofile 
warning: /no-vmlinux could not be found.
<?xml version="1.0" ?>
<profile  schemaversion="2.0" cputype="x86-64"
 processor="hammer"
 separatedcpus="2"
 mhz="1000"
 title="opreport -wdlX --session-dir /var/lib/oprofile ">
<options  details="true"/>
<setup>
<eventsetup  id="0" eventname="CPU_CLK_UNHALTED" unitmask="0" setupcount="2000000"/>
</setup>

bfd_get_section_contents:get_debug:: Bad value
-------------------- END ---------------------

Expected results:
Please see the attached opreport-good.xml (the XML output using the upstream Oprofile-0.9.4)
Comment 1 Suravee Suthikulpanit 2009-03-10 15:45:19 EDT
Created attachment 334704 [details]
This is a good version of the XML output.
Comment 2 William Cohen 2009-04-09 12:22:44 EDT
I am wondering if this might be another symptom of bz467651. The problem only appeared on i386. Could you check that to see whether the latest build of oprofile for F-10 resolves this problem:

http://koji.fedoraproject.org/koji/buildinfo?buildID=97193
Comment 3 Suravee Suthikulpanit 2009-04-09 13:34:09 EDT
The problem seems to be fixed in the oprofile-0.9.4-6.fc10.i386.rpm . Please push the packages from this build to the F10 update through Bodhi.

Thank you
Comment 4 Fedora Update System 2009-04-09 14:44:29 EDT
oprofile-0.9.4-6.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/oprofile-0.9.4-6.fc10
Comment 5 Fedora Update System 2009-04-13 15:39:33 EDT
oprofile-0.9.4-6.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update oprofile'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3558
Comment 6 Fedora Update System 2009-04-17 14:03:39 EDT
oprofile-0.9.4-6.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.